[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Font corruption under X



* Mike Werner in "Font corruption under X" dated 2000/07/08 19:36
* wrote:

> Hiya folks.  Some time back I started having a strange and sporadic
> problem with the displayed fonts in X becoming corrupted.  Recently
> it started happening more often.  I've not been able to determine
> what causes it, but it happens more easily when Netscape is running. 
> I don't think I could describe what happens to the fonts, so I won't
> try.  Instead, I got a screenshot of it.  It's at:
> http://www.csee.wvu.edu/~mwerner/netscape.jpg

Heh, I had that problem too, a while back.

> Recently, if I copy a URL using the mouse from an xterm (actually,
> it's rxvt that I use) and then paste it into Netscape's URL window
> the font corruption happens almost immediately.  If it doesn't happen
> immediately, scrolling up and down a few times with the Page-Up and
> Page-Down keys will trigger it.

Mine was never that consistent though.

> However, I'm just about positive it's *not* Netscape's fault.  I've
> had this font corruption happen even if Netscape is not running. 
> It's happened with FileRunner, mutt (running in an rxvt window), mc
> (also in an rxvt window), and even just in rxvt at a prompt.  There
> may have even been other apps that it's happened with - the 4 listed
> are the one's I use the most.
> 
> I've also determined that it happens whether I have Gnome running or
> not.  And I just tried with a different window manager - I usually am
> using Sawfish under Gnome, installed blackbox and tried under that -
> with the same results.  It would seem that the fault is with X itself
> somewhere, but I have no idea where.  And since I've no idea where to
> look next I'm not sure what to do next.

I came to the same conclusion that it had to be something in the X
server but what exactly I don't know.

> I'm running woody up-to-date as of 5 minutes ago, kernel 2.2.16, PII
> 300MHz, 64 megs RAM, Helix Gnome / Sawfish.

What video card are you using? I noticed this on a cheap S3
Virge/something (dx i think), upgrading my video card to a Matrox G200
seems to have solved the problem so I suspect it had something to do
with the S3V implementation of the SVGA X server, but I'm still only
guessing.

-- 
Ashley Clark

GCS/M d- s:-- a-- C++$ UL++++$ P+>+++ L+++ E W++ N+ o K++ w O M V--
PS+(++) PE(++) Y+ PGP++(+++) t* 5+ X+ R* tv b+ DI++ D G e* h* r++ y+

finger aclark@ghoti.org for GPG public key            http://ghoti.org/

Attachment: pgpR2qN5Xh0Mr.pgp
Description: PGP signature


Reply to: