[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Font corruption under X

Hiya folks.  Some time back I started having a strange and sporadic problem
with the displayed fonts in X becoming corrupted.  Recently it started
happening more often.  I've not been able to determine what causes it, but
it happens more easily when Netscape is running.  I don't think I could
describe what happens to the fonts, so I won't try.  Instead, I got a
screenshot of it.  It's at:

Recently, if I copy a URL using the mouse from an xterm (actually, it's rxvt
that I use) and then paste it into Netscape's URL window the font corruption
happens almost immediately.  If it doesn't happen immediately, scrolling up
and down a few times with the Page-Up and Page-Down keys will trigger it.

However, I'm just about positive it's *not* Netscape's fault.  I've had this
font corruption happen even if Netscape is not running.  It's happened with
FileRunner, mutt (running in an rxvt window), mc (also in an rxvt window),
and even just in rxvt at a prompt.  There may have even been other apps that
it's happened with - the 4 listed are the one's I use the most.

I've also determined that it happens whether I have Gnome running or not. 
And I just tried with a different window manager - I usually am using
Sawfish under Gnome, installed blackbox and tried under that - with the same
results.  It would seem that the fault is with X itself somewhere, but I
have no idea where.  And since I've no idea where to look next I'm not sure
what to do next.

I'm running woody up-to-date as of 5 minutes ago, kernel 2.2.16, PII 300MHz,
64 megs RAM,  Helix Gnome / Sawfish.

Anyone out there ever seen anything like this?
Mike Werner  KA8YSD           |  "Where do you want to go today?"
                              |  "As far from Redmond as possible!"
'91 GS500E                    |
Morgantown WV                 |  Only dead fish go with the flow.

Reply to: