[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems with modules

Larry Elmore wrote:
> I just installed 'Woody' and am having odd problems with a couple of
> modules. The 'lp' module claims that options passed to it in 'modules.conf'
> are bad, yet they are exactly the same options I previously used with
> 'Slink':
>         options lp io=0x378 irq=7
> Also, my SoundBlaster 16 which previously worked using these settings:
>         options adlib_card io=0x388'
>         options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330
> but now fails to work. The drivers are loaded, then ('dmesg' reveals), the
> dsp fails to reset and apparently everything is then unloaded ('cat <
> /dev/sndstat' shows nothing loaded). 'modprobe sb' fails with message that
> "device is busy" and module parameters may be wrong.
> I used the same options in configuring the kernel for recompilation that I
> used before (I'd taken notes) and as far as I can find out in the HOWTO's, I
> did everything right. So does anybody have any idea what's going on here?
> Help!
> Thanks,
> Larry

Hi Larry,
It seems (I didn't prove it) the part of the parallel port in the kernel
has changed a lot from 2.0 to 2.2. (Tree modules instead of one.) I had
similarly problems and solved them by linking the code directly into the

It seems also that the code doesn't support interrupts at the parallel
port. The program tunelp -i replys an error of ioctl.

Sorry, with SoundBlasters I don't have any experience.


Reply to: