[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: init question

Bruce Sass wrote:
> On Wed, 14 Jun 2000, Tom Glass wrote:
> > I'm attempting to modify runlevel 5 to start my own app.  As a start, I
> > deleted all links from /etc/rc5.d and replaced them with links copied in
> > from /etc/rc1.d.  (i copied rc5.d into my home directory first in case I
> > need it later).  I thought when I did this that init 5 would now behave
> > exactly as init 1, but it doesn't.  init 5 (typed in as root from a
> > console) doesn't cause any error, but it also doesn't do anything that I
> > can tell.  init 1 on the other hand closes X and starts single user
> > mode.  Can someone please tell me what I'm doing wrong?
> Single user mode is handled differently than the multiuser runlevels by
> "init", perhaps you are running up against that fact ("man init"
> mumbles about it a bit).  Have you duplicated in rc5.d the link named
> "S20single" in rc1.d; maybe remove it, init could be getting confused
> by being asked to start runlevel S when in runlevel 5. 

yeah maybe you're right.  I tried removing the link in question and I
still get no change that I see.  It is the only S link in rc1.d and if I
understand correctly, the K links are only executed when I _leave_ the
runlevel. so when I remove it from rc5.d then nothing should be executed
on starting runlevel 5, right?

> Hmmm, the K??*
> links should still work though... what does "ls -l /etc/rc5.d" show?

I can't seem to get this to paste into netscape (my mail manager), but
it shows 18 symbolic links to files in the /etc/init.d directory, and
looks just like the listing of /etc/rc1.d.
> - Bruce

Reply to: