[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X forwarding using openssh.

ive seen a few posts about this in the list but i still can't get it

here's what i got goin.

1 Debian GNU/Linux 2.2 machine running OpenSSH 1.2.3
1 Linux Mandrake 7.1 machine running OpenSSH 1.2.2

both are on the same (local) network. infact they are with 15 feet of each
other.  but i wanna do this to reduce resource usage on my desktop
machine(yesterday i was swapping full 128MB with only 128MB of ram, too

both machines are configured for SSH forwarding, when i login to the
mandrake box:

aphro@xxx.xxx.xxx.xxx's password: 
debug: Requesting compression at level 6.
debug: Enabling compression at level 6.
debug: Requesting pty.
debug: Requesting X11 forwarding with authentication spoofing.
debug: Requesting shell.
debug: Entering interactive session.
Last login: Wed Jun  7 17:05:10 2000 from aphro
[aphro@ip-133 aphro]$ 

when i try to run an X app, take kedit for example:

[aphro@ip-133 aphro]$ kedit
debug: Received X11 open request.
debug: channel 0: new [X11 connection from ip-133.some.domain.net port
debug: X11 connection uses different authentication protocol.
X11 connection rejected because of wrong authentication.

debug: X11 rejected 0 i1/o16
debug: channel 0: INPUT_OPEN -> INPUT_WAIT_DRAIN [read failed]
debug: channel 0: shutdown_read
debug: channel 0: OUTPUT_OPEN -> OUTPUT_WAIT_IEOF [write failed]
debug: channel 0: shutdown_write
debug: X11 rejected 0 i2/o64
debug: channel 0: INPUT_WAIT_DRAIN -> INPUT_WAIT_OCLOSE [inbuf empty, send
debug: channel 0: OUTPUT_WAIT_IEOF -> OUTPUT_CLOSED [rvcd IEOF]
debug: channel 0: INPUT_WAIT_OCLOSE -> INPUT_CLOSED [rcvd OCLOSE]
debug: channel 0: full closed
kedit: Fatal IO error: client killed

I tried adding xauth stuff:

[from mandrake]
xauth list says:

ip-133.some.domain.net/unix:0  MIT-MAGIC-COOKIE-1
ip-133.some.domain.net:0  MIT-MAGIC-COOKIE-1
ip-133.some.domain.net/unix:10  MIT-MAGIC-COOKIE-1
ip-133.some.domain.net/unix:11  MIT-MAGIC-COOKIE-1

[from debian]
xauth says

ip-197.some.domain.net:0  MIT-MAGIC-COOKIE-1
fe19bd06799125a48c7bce3cb0ba8af0  MIT-MAGIC-COOKIE-1  fe19bd06799125a48c7bce3cb0ba8af0
ip-197/unix:0  MIT-MAGIC-COOKIE-1  fe19bd06799125a48c7bce3cb0ba8af0
ip-133.some.domain.net/unix:11  MIT-MAGIC-COOKIE-1
ip-133.some.domain.net/unix:10  MIT-MAGIC-COOKIE-1

tried several different variations of the xauth settings on both sides to
no avail.

I don't need ssh to do this but it would be nice. any help ? please cc to
meif possible my other account doesnt seem to be recieving list email
(nate@firetrail.com) i think its a DNS issue(on my end) the domain on this
account works though.


5:30pm up 11 days, 2:31, 1 user, load average: 0.21, 0.08, 0.01

Reply to: