[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: E: Internal Error. Cannot configure a pre-depend?

> -----Original Message-----
> From: Bruce Sass [mailto:bsass@freenet.edmonton.ab.ca]
> Sent: Friday, June 02, 2000 03:08
> To: Ron Rademaker
> Cc: niCLam; debian-user@lists.debian.org
> Subject: Re: E: Internal Error. Cannot configure a pre-depend?
> On Thu, 1 Jun 2000, Ron Rademaker wrote:
> > Your upgrade gives you some trouble, I've had it too, the 
> way I fixed it
> > is not a real nice way but it worked. I did the following:
> > 
> > Went to the directory where apt downloaded to, used dpkg 
> several times
> > with all kind of --force options, after lots of puzzling 
> which package I'd
> > do next and what force option I should use this time, 
> finally... finally
> > my system was upgraded and running.
> > 
> > If anybody has other ideas, you should probably try those first.
> Some of the messages spit out when you run into a predepend problem
> should tell you what packages are involved; manually install and
> configure the package that is predepended on, then pickup 
> were you left
> off.  "dpkg --configure-pending" is a good thing to do, and may even
> solve the predepend problem.
> later,
> 	Bruce

I failed to identify which of the many packages I had downloaded caused the
problem and choked apt-get (-s). How do you do this?
Generally speaking, would it be difficult to enhance this rather cryptic
error message a bit? From the number of posts, this problem does seem to
occur every so often. 

Eventually, in my case it helped to upgrade the apt package (from
apt_0.3.10slink11 to apt_0.3.18, while I was trying to hack the error
message - thus I never knew if that was successfull ;-). However, that was
more than a month ago and may be outdated now.


Reply to: