[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unusual Lilo "LI" problem

On Mon, 03 Apr 2000 11:13:37 David Wright wrote:
> > This brings up a new question.  LILO 
> > keeps setting hda1 as the first drive.  Is there a way to get it to 
> > think of my SCSI disc as the first drive and still have the IDE 
> > connected?  Thanks for all your help.
> I don't think this is a lilo issue, but a BIOS one. If you can't set
> the scsi drive as the boot device in the BIOS, then you'll have to
> install your boot loader on the ide disk as the BIOS will always go there
> first. Of course, you might want to install it on both disks so that
> you don't have to worry if you remove the ide drive again.

That's what I thought, however my BIOS does have the option to boot from 
a SCSI device or any IDE drive.  It works great booting my hard drive or 
SCSI CDROM.  The problem occurs when I run LILO.  Using lilo -v, it 
detects hda1, and gives me the warning message that sda2 is not on the 
first disc which leads to me getting "LI" at boot.  I'm thinking the 
BIOS might still report the IDE as the first device, but boot from the 
SCSI.  Don't know really.  Last night, I tried putting the IDE drive on 
the secondary IDE controller, and that also worked.  I only use it for 
backups, so this seems to work now (unless I get more than 2 IDE devices 



Reply to: