[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: zip and parport printer sharing??

Quoting Gregory Guthrie (guthrie@mum.edu):
> If I try to use my printer, downstream from a Zip parallel device, I get 
> "Status: cannot open, /dev/lp1 - device not configured"
> But if I power down the Zip pre-boot, it works fine.
> I am running Debian 2.1R4.

Well, yes, I think I saw you report this before, and I hadn't got
round to replying. You give no details about your kernel version
2.0/2.2 or about whether ppa and lp are compiled in or modules.

With modules, and with ppa in /etc/modules, I would expect (from
memory) that you'd get the effect you describe:
zip on at boot: ppa module loaded, printer won't work at the same time
unless you rmmod ppa and then insmod lp (or let it be insmod'ed).
zip off at boot: ppa module doesn't load, printer then works as long
as the zip drive is then switched on (IIRC).

I have no idea how all think works if the modules are built-in, but
it could well be just as you describe for similar sorts of reasons.

>  From Zip-Drive mini-HowTo:
> "As of kernel version 2.2.x you can do parallel port sharing. This means 
> that you can plug the
>                            printer into the zip drive and use both the zip 
> drive and the printer. I tried this on my machine
>                            and it worked like a charm. "

That's right. Again for modules, you'd insmod them in the order
parport, lp, parport_pc, ppa, and it'll work like a charm.

Two things: modules allow you to connect/disconnect the drive
without rebooting. 2.2 kernels configure the parallel ports
differently so your 2.0's lp1 will probably become 2.2's lp0.


Email:  d.wright@open.ac.uk   Tel: +44 1908 653 739  Fax: +44 1908 655 151
Snail:  David Wright, Earth Science Dept., Milton Keynes, England, MK7 6AA
Disclaimer:   These addresses are only for reaching me, and do not signify
official stationery. Views expressed here are either my own or plagiarised.

Reply to: