[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Oh no, not another AWE64 question



Friends.. I an in terrible need of help, and I know how much people hate
questions about soundcards, especially AWE64s, but you are my last
resort..

I've tried to get my AWE64 PnP card working for many days now, to no
avail.. first I tried using OSS modules as many other people suggested
when I researched old archives. Upon bootup I would get an error saying it
failed on IRQ 7 or something to this degree.. doing a cat /proc/interupts
showed me a sound blaster 16 under irq 7, not 5 like it should be..

So my next step was to try ALSA drivers.. I've successfully installed
these before when I ran slackware. I believed I followed the instructions
accurately.. anyhow, here is some info..

underworld:/home/charon# lsmod
Module                  Size  Used by
vfat                    9372   1  (autoclean)
fat                    30304   1  (autoclean) [vfat]
snd-card-sb16           4976   0  (unused)
snd-mpu401-uart         3300   0  [snd-card-sb16]
snd-rawmidi            11352   0  [snd-mpu401-uart]
snd-seq-device          3788   0  [snd-rawmidi]
isapnp                 27156   0  [snd-card-sb16]
snd-opl3                2628   0  [snd-card-sb16]
snd-sb16-csp           17332   0  [snd-card-sb16]
snd-sb16-dsp           18472   0  [snd-card-sb16 snd-sb16-csp]
snd-pcm                36696   0  [snd-sb16-dsp]
snd-timer              10688   0  [snd-opl3 snd-pcm]
snd-hwdep               3756   0  [snd-opl3 snd-sb16-csp]
snd-mixer              29552   0  [snd-sb16-csp snd-sb16-dsp]
snd                    44684   1  [snd-card-sb16 snd-mpu401-uart
snd-rawmidi snd-seq-device snd-opl3 snd-sb16-csp snd-sb16-dsp snd-pcm
snd-timer snd-hwdep snd-mixer]
soundcore               2788   2  [snd]
3c59x                  18720   1

this is after a modprobe snd-card-sb16 as instructed in the alsa install
howto ..

underworld:/home/charon# cat /proc/asound/cards
0 [card1          ]: SB16 - Sound Blaster 16
                     Sound Blaster 16 at 0x220, irq 5, dma 1&5

underworld:/home/charon# amixer set Master 15
Group 'Master',0
  Capabilities: volume
  Channels: Front-Left Front-Right
  Limits: min = 0, max = 31
  Front-Left: 15 [48%] [on] [---]
  Front-Right: 15 [48%] [on] [---]

Playing a cd in grip works though.. 

Trying to play an mp3 using xmms gives me an error telling me 3 things,
the most significantly being that my sound isn't configured properly. I am
at a loss, and am uncertain how to proceed. I would very much appreciate
it if some kind soul could offer some assistance.. 

BTW, I'm running frozen with a fresh 2.2.14 kernel and I have sound
support configured as a module.. 

Thanks



Reply to: