[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems after upgrading


I have been having some problems here and would like to hear of your
thoughts. The latest pppd gives me the following message after a first pon <provider>:

Can't open pty slave /dev/pts/0: File or directory not found

Well, in fact that happens only after the first pon, then goes away. But
the kernel keeps sending these ones after every ppp call:

Feb  1 20:04:24 cdemo modprobe: modprobe: Can't locate module char-major-108

And I've also got several mouse problems. I've adopted the solution of
running gpm as -R and then selecting the mouse as /dev/gpmdata when
configuring x, because if I haven't done that, I couldn't switch between x
and the console (I could, but then I would come back and x would freeze.
*always*.) But that is really annoying, because the mouse now bugs
x just like it bugs the console (random pasting, and all that gpm trouble
:(), and the following startup errors:

 -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xkbcomp are not fatal to the X server" keymap/xfree86 /var/tmp/xfree86.xkm'
Warning: /dev/gpmdata unable to get status of mouse fd (Invalid argument)

(after exiting x11:)
waiting for X server to shut down

cdemo:~$ X connection to :0.0 broken (explicit kill or server shutdown).

So it quits like if it was killed, when all I've done was select "Exit"
(so x should quit normally?). I'm also obligated to kill gpm every time I
run another application using the mouse without going thru gpm, like
quake/quakeworld, and then rerun it when I quit the game. If you are able
to give me some help with any of these problems, reply to my normal mail
address (I am not currently subscribed to debian-user, because of its very
high traffic). I'd appreciate any help.


Carlos Laviola
If you want my PGPi/GnuPG keys, finger claviola@ukug.uk.freebsd.org.

Reply to: