[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kdevelop configuration (debian)



Achim Bohnet wrote:
> >>>"Stephen R. Gore" wrote:
>  > Setting up kdevelop (1.0-19991009-1) ...
>  > cannot open dhelp file '/usr/share/doc/HTML/en/kdevelop/.dhelp':
>  > at /usr/sbin/install-docs line 559.
>  > 
> Are you sure /usr/share/doc/HTML/en/kdevelop/.dhelp exists?

Actually, I'm sure that it doesn't exist below /usr/share/doc/HTML.
AFAIKT, kdevelop never adds it's dir structure there.  I've tried to add
it manually, but the added dirs get removed when I attempt to finish
configuring.

> The KDE packages currently install below /usr/share/doc/HTML/ which is no
> good idea.  AFAIU dhelp_parse -r removes the tree /usr/share/doc/HTML
> and rebuilds it from scratch with all .dhelp files in /usr/share/doc.
> Result is that all KDE HTML docs vanish from time to time when packages
> are upgraded.   This will be fixed in the kde packages in the near future.
> 

This would explain why the manually added dirs vanish.

I've just tried replacing libqt1g with qt1g and qt1g-dev, and building the
original source tarball.  This fails in the configure stage, not being able
to recognize the qt1g libraries and includes:

	checking for Qt... configure: error: Qt (>= 1.42 and < 2.0) (headers
	and libraries) not found. Please check your installation!

dpkg -s qt1g-dev:

	Status: install ok installed
	Version: 1:1.44-6.1

Has anyone succesfully installed/compiled kdevelop on a current potato box?
-- 
Regards,
Steve

Debian GNU/Linux Because software support is free, timely,
                 useful, technically accurate, and friendly.
                 Reboots are for kernel and hardware upgrades.


Reply to: