[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Potato broke my mouse in X?



Aaron Solochek wrote:
> 
> I just installed a potato partiton, all seemed to go well.  I even
> installed accelerated X on it, and its setup didn't segfault, an obvious
> improvement.  The first time I ran X everything worked fine.  Then, out
> of the blue, the mouse stopped working in X.

I get this too, from time to time.  Could this be an Xserver issue?  I'm
using the xserver-svga 3.5.5-1 package with, I believe, a Matrox
Millenium G200 video card.  I haven't found a way to fix it, but I did
discover quite accidentally that if I switch to a console tty, then back
to my X tty, it restores control to the cursor...after a little
weirdness.  The first time you move the mouse after switching back,
it'll spaz out, emitting a couple random click events and landing in the
upper right corner.

I'm also using CVS Enlightenment as my window manager, but I highly
doubt that's related.

So, try a <Ctrl><Alt>F6 then an <Alt>F7 and see if you get your mouse
back.

HTH,
John


Reply to: