[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

external modem problem

I'm having a problem with an external US Robotics 56K Faxmodem.  I'm
running a Potato system with the 2.2.12 kernel on a Toshiba Tecra
700CT.  I have never gotten the modem to work with Linux before, but I
have used it with Windows.

The problem is this: when I run Minicom (or anything else that requires
the modem) the modem is unresponsive.  The TR light -- Data Terminal
Ready light -- gets lit up and the modem won't "talk" to the software.
The same light also goes on when I run statserial to check the serial

However, there is definitely some communication between the OS and the
modem.  When I exit Minicom or statserial the TR light goes off.  Also,
when I re-initialize the modem within Minicom the light temporarily goes
off.  Also, when I updated my ppp connection with pppconfig I told it to
search for all available modems and it found the modem (which is
attached to /dev/ttyS0); when it was searching, all the lights on the
modem briefly flashed.

I've checked the dip switches on the modem and they seem fine -- they
are set to the factory default, which includes the DTR switch off (I've
tested it with it on as well; no good).  The serial port, /dev/ttyS0,
also seems fine.  I have support for the serial port loaded as a module
and when I type lsmod it shows up.  I don't think I have a getty running
on the serial port (I checked /dev/ttyS0).  The info from setserial
seems fine and I don't think that I have any conflicts (from

I'm stumped and any help would be much appreciated, especially since
I've managed to disable my PCMCIA modem (which may soon be the subject
of another post).


Reply to: