Re: Slink to Potato
"Damir J. Naden" <firstname.lastname@example.org> writes:
> I have been told that glibc2.1 and glibc2.0 are binary compatible.
For most purposes, they are. Of course this is software, and software
has bugs, so there are almost certainly odd cases where things don't
work; but they appear to be quite the exception.
> Why, then, do we have _all_ the packages in the potato _dependant_ on
> libc6 _=>2.1_ and not just libc6 period.
I do not know. I assume it's probably because they use features that
are in 2.1 but not 2.0 (note that `binary compatible' doesn't mean that
they present *exactly* the same interface, merely that 2.1 should
present *at least* the same interface as 2.0).
> And why do I get Navigator 4.7 giving me all sorts of errors when I do
> ignore-depends on libc6 =>2.1 if I have libc6 2.0 installed (the one
> from netgod- navigator,that is)?
I do not know; you'd have to post the errors.
> You have "mixed" enviroment, apparently. But, if you didn't have
> glibc2.1, _none_ of the potato packages would have installed in the
> first place, because of the missing dependancies (if you used dpkg).
This is not true; much depends on glibc >= 2.1, but quite a bit doesn't
care at all (note that I didn't upgrade to glibc2.1 immediately, only
when I wanted to check out a recent version of enlightenment).
> And if upgrading libc6 2.0 to 2.1 is going to be anything like
> upgrading from libc5 to libc6 I shudder at the idea of sitting in
> front of the screen waiting to crash it to the point of no return.
That was supposed to be the point of my message -- In my experience,
upgrading from glibc 2.0 to 2.1 is *trivial*, and needs no special
consideration, migration guides, hand-holding sessions, or support
Stop whining and just do it.
p.s. The `stop whining' bit was for dramatic effect only.
Love is a snowmobile racing across the tundra. Suddenly it flips over,
pinning you underneath. At night the ice weasels come. --Nietzsche