[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Slink to Potato

Hi Miles Bader; unless Mutt is confused, you wrote:
> Damon Muller <dm-debian-user@empire.net.au> writes:
> > Because of the developments such as glibc2.1, perl, and probably
> > numerous other things, you can't take something out of Potato and put it
> > on a Slink system and expect it to work. It's an all-or-nothing
> > arrangement. They may both be `GNU/Linux', but they are essential
> > incompatible.
> This is simply not true.
> As I have mentioned in several other posts recently, I've been
> incrementally upgrading my slink system with packages from potato, using
> no particular care, simply depending on dselect/apt to keep me safe.
> I _have_ upgraded to glibc2.1 and the new perl, but these upgrades were
> quite painless, and had no obvious negative repercussions -- the great
> majority of stuff on my system is still slink (from a japanese cdrom
> set, BTW, which had all sorts of wacky-ass versions of things...) and it
> all works together quite happily.
> In case you hadn't notice, dselect/apt/&c do their job quite well.
> I suggest you take a deep breath and give them a try (instead of getting
> all freaked out by what you read on mailing lists and crying doom).
> The beauty of debian is that the package maintainers do the worrying and
> the awful kluges (and they've done a wonderul job), meaning *you* don't
> have to!
> Cheers,
> -Miles

I have been in this thread way too long :-), but ... I have to agree
with Damon's post. And I have been told that glibc2.1 and glibc2.0 are
binary compatible. Why, then, do we have _all_ the packages in the
potato _dependant_ on libc6 _=>2.1_ and not just libc6 period. And why
do I get Navigator 4.7 giving me all sorts of errors when I do
ignore-depends on libc6 =>2.1 if I have libc6 2.0 installed (the one
from netgod- navigator,that is)? You have "mixed" enviroment,
apparently. But, if you didn't have glibc2.1, _none_ of the potato
packages would have installed in the first place, because of the missing
dependancies (if you used dpkg). And if upgrading libc6 2.0 to 2.1 is
going to be anything like upgrading from libc5 to libc6 I shudder at the
idea of sitting in front of the screen waiting to crash it to the point
of no return. Can anyone of the Debian management find some time in the
near future to write up a definitive migration guide (ie. what needs to
be updated as a very minimum, in which order and such- like the one we
had for libc5->libc6 thing)?
And I agree with Damon also in the point that I'm _extremly_ grateful to
Debian management and developers for their work, and my posts should not
be taken as a criticism, but practical concerns from the end-user
standpoint. I have no Windows on my machine, and if I crap out this box
trying to upgrade, I can't even post for help once the machine is
down... Occasional instability or insecurity is not as much of a concern
as that.


Reply to: