[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: pcmcia net card does not show up in "ifconfig" listing.

On Thu, 30 Sep 1999, Pollywog wrote:

> On 30-Sep-99 Hugo van der Merwe wrote:
> > I realise something is probably not configured correctly. I installed
> > pcmcia-source, and compiled it with dpkg-kpkg, then installed the
> > resulting .deb file. Everything seems to be working fine, except that I
> > expected the network card in the slot to show up when I run ifconfig. It
> > does not. 
> > 
> What happens when you do (as root):
> /etc/init.d/network start   ?

/etc/init.d/network contains the following 3 lines:

#! /bin/sh
ifconfig lo
route add -net

Needless to say, it doesn't do much... but it is identical to the script
on the other laptop. Clearly the pcmcia stuff is not found in that script.

/etc/init.d/pcmcia start  does not solve the problem either. sum pcmcia
and cksum pcmcia gives the same result on both laptops, so I assume the
scripts are identical, so the fault is not in that script either. Most of
the configuration stuff for pcmcia seems to be in /etc/pcmcia. Shall I
start comparing files in that directory?

Hugo van der Merwe

Reply to: