[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fatal error in SO 5.1

"Damir J. Naden" wrote:
> Hi Brad; unless Mutt is confused, you wrote:
> > On Sun, 3 Oct 1999, Robert Rati wrote:
> >
> > > I've read the mailing list archives about the various Star Office
> > > problems in potato, and something tells me that people are on the
> > > wrong track.  I am currently getting a "Fatal Error" about 10 seconds
> > > after I load Star Office.  Many of the posts that solve Star Office
> > > 5.1 problems (which is what I have) seem to revolve around doing some
> > > trickery to use glibc 2.0.

	Your fatal error problem is not related to the discussions on deb.usr
of SO 5.1 recently.  I've never seen it, sorry.

> >
> > Except for the problems with threaded system(3) calls in ove of the glibc
> > 2.1.2 prereleases, all the solutions you mention solve problems for
> > StarOffice 5.01 (which had problems with glibc 2.1), not StarOffice 5.1.

	There may have been problems with earlier versions of SO, I only showed
up for 5.1, however there *were* glibc2.1 problems for SO 5.1.  The
first version I downloaded from the Star Division web site failed after
an upgrade of glibc2.1 of the potato distribution.  I made an attempt to
have both glibc2.07 and glibc2.1 on the system to get SO to work, but
the instructions failed for me.  For me the solution was "solved" (not
exactly sure) when I downloaded the new SO tarball (so51a_lnx_01.tar,
note the "a") from Sun's website (stardivision.com will now redirect to
sun.com).  This one worked without problems with glibc2.1.x.  There were
however later upgrades to glibc in that time, but I think it wasn't
glibc, they did something with the new version of SO to solve the

> >
> > > Does anyone know how to solve the "fatal error" problem in Star Office
> > > 5.1 on potato?  Any help would be appreciated as this has me rather
> > > perplexed.
> >
> > Can't help because i've never seen the error. Then again, i don't use SO
> > for email or anything.
> This is interesting. Are there two different SO5.1 out there? I'm
> running 5.1, downloaded from then StarDivision Web-site, on a slink
> system with libc6 2.0 without a hitch (and, no, I didn't install any
> libc6 libs from their package). My ldd output (only libc shown):

	With glibc2.0.x, the original tarball from stardivision.com would work
fine, but that version only works for systems with glibc2.0.x.  Those
who have upgraded to glibc2.1 either have to modify their system (and
install two versions of glibc), or download the newer tarball from Sun.

	WARNING:  getting the tarball from sun.com is now worse than it was
when getting it from stardivision.  There is no simple ftp access to the
tarball; you have to go thru an obscene sequence of web pages (they want
everything, including your mom's maiden name) then click on a final link
(a very complicated link; saving this long link won't help) to download
the tarball.  In this case the download failed the first two times and I
could never resume the download without starting all over.  Make sure
you have a strong net connection before trying the download, if your
link drops during the download you'll have to start all over.

Ed C.

Reply to: