[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Obscure ethernet/IDE trouble



rick wrote:

> "In article <37CD3856.521807EB@mit.edu> you wrote:"
> > Greetings,
> >
> > I'm having bizarre troubles with the base 2.1 system (2.0.36-scsimod) on
> > an Abit BP6 dual-celeron system with Triton IDE DMA chipset and twin
> > 3C905 ethernet cards.  After my first net access (via eth0), be it ping
> > or apt-get update or whatever, the next disk access causes an IRQ
> > problem:
> >
> > hda: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
> > hda: disabled DMA
> > hdb: disabled DMA
> > [same for hdc and hdd]
> > ide1: reset: success
> > ide0: reset: success
> >
> > so IDE-DMA gets dropped and the interfaces reset, after which the net is
> > inaccessible!
>
> I was getting the 'DriveReady SeekComplete DataRequest' error and
> related hard drive problems after I selected the 'use DMA when
> available' when configging the kernel source.  Although I don't
> have the flakey chipset mentioned in the help for this option,
> deselecting the option fixed the problems.

I'm using the 2.0.36-scsimod kernel which comes with the base_2.1.  I don't think
this uses DMA by default.  Even the newer .config files don't come with that config
flag set, from what I've seen.

William T Wilson wrote:

> On Thu, 2 Sep 1999, rick wrote:
>
> > I was getting the 'DriveReady SeekComplete DataRequest' error and
> > related hard drive problems after I selected the 'use DMA when
> > available' when configging the kernel source.  Although I don't
>
> I get this all the time when I try to access a drive that is in sleep
> mode.  It takes it a minute or two and then it comes back to life and
> works normally.  I have an old '96 era Intel Triton motherboard.

Okay, but why would my drives be sleeping?  This happens during the first disk access
after a net access, could the net driver be putting the drives to sleep?  And why
does resetting the IDE interfaces kill my networking ability?

Example: I cold boot, login as root, and can ping to my heart's delight, then I
dselect-> update, and it manages to download the first 20K or so with no problem,
then this IDE error, and the net dies!

Freaky, eh?

Thanks,

-Adam P.



Reply to: