[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Obscure ethernet/IDE trouble


I'm having bizarre troubles with the base 2.1 system (2.0.36-scsimod) on
an Abit BP6 dual-celeron system with Triton IDE DMA chipset and twin
3C905 ethernet cards.  After my first net access (via eth0), be it ping
or apt-get update or whatever, the next disk access causes an IRQ

hda: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
hda: disabled DMA
hdb: disabled DMA
[same for hdc and hdd]
ide1: reset: success
ide0: reset: success

so IDE-DMA gets dropped and the interfaces reset, after which the net is

There shouldn't be an IRQ conflict, because the net cards are on IRQs 10
and 5, and the ide0 and ide1 are at 14 and 15 respectively.  I tried
network stop; ifconfig eth0 down; rmmod 3c59x; modprobe 3c59x; network
start but the network is still dead.  It remains dead until I do a full
halt and power down, after which it comes back- until the next disk

Okay, here's another: I halt, hit reset, it boots, and now I get:

eth0: Host error, FIFO diagnostic register 8000.

repeated over and over, interspersed with another error message which I
can't see (it's scrolling too fast) except that it ends in "Temporarily
disabling functions".  Sometimes.  Sometimes I just don't see this
problem at all.  But it sounds related to the other problems.

I suppose I could get a CD-ROM and buy a slink CD, but that would cost
more money and take more time and not necessarily solve the problem.  I
can't download the system of course because the net is dead.  Maybe I
should try installing RH6 from the net, using the more recent drivers,
and then somehow get Debian with a more recent kernel into another
partition...  Is there a base2_2.tgz that I haven't been able to find?

So that's the problem as it exists today.  Now for some history.

The funny thing is that this problem didn't exist until I went into the
BIOS and "manually autodetected" the hard drive configurations.  You
see, I bought four identical hard drives to make a RAID5 array (haven't
tried this, so don't reply on this subject, I know it might not be
possible), but one autodetected slightly differently from the others.
Three autodetected as 16 heads, the fourth as 255 heads, so the
partition sizes weren't identical, which I think is a no-no for RAID.
So, figuring the fourth was defective, I returned it for a new one
(which also autodetected as 255 heads).

But in the meantime while waiting for the new drive, I had installed a
very nice slink/GNOME system on small identical partitions of the
original three drives (so I could later stripe large partitions
together).  The network was fine, everything was great.

Then the new drive arrived, and autodetected as 255 heads, and I was
very sad.  So I looked around the BIOS, where there was a hard drive
autodetect function, and I found I could switch the configuration to 16
heads.  Awesome!  So, I did so, and re-partitioned, all the small and
large partitions were the same size across all the disks, cool.  It
installed, it booted, it networked, it was grand.

Then I upgraded to potato.  (Why?  I don't know, but had something to do
with the newer GNOME updates.)  This happened to be at the time a couple
of days ago when netbase had some broken/missing dependencies, so when I
rebooted, the network didn't work.  (Of course, I didn't connect the two
problems until the same trouble came up on my laptop...)

So I decided to go into the BIOS and configure all of the IDE drives
manually in the 16-head setup.  This didn't solve the problem, so I
figured I had a hosed system, and did a complete reinstall.

Since then, I have had the problem described above.  I tried undoing the
16-head config busines, but the problem persists!  I unplugged the hard
drives, rebooted, plugged them in, reinstalled, no luck.  (I reinstalled
about five times last night :-)

On some of the reinstalls, I tried to use both the nfs and 3c59x
modules, but this caused fatal ethernet errors before I could put in the
first base system disk.  But this is a separate problem.

So I'm all out of ideas.  Running out of hope.  "Help me Obi-wan Kenobe,
you're my only chance."  Please.  Someone.  I don't like having a dead
system, and I've worked so hard for it- it would be a cool system if it
only worked.  And I'm surrounded by NT users who just buy stuff from
Dell, and don't want them to laugh at me for trying to assemble the box
and install Debian myself. :-)

Forever grateful to whoever can help,

-Adam P.

Reply to: