[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with /etc/ppp/ip-up.d/



On Fri, Jul 16, 1999 at 08:45:12PM -0500, Brian Servis wrote:
> *- On 17 Jul, Alisdair McDiarmid wrote about "problem with /etc/ppp/ip-up.d/"
> > i want to start xnetload on ppp up, and kill it on ppp down. so i
> > wrote two scripts: /etc/ppp/ip-up.d/load:
> > 
> > when i connect, nothing happens. if i type /etc/ppp/ip-up.d/load
> > at the command line, xnetload is loaded. if i then disconnect, the
> > other script kills it.
> 
> I assume you are running X as a normal user.

yes, but running the script as root, manually, works fine.

> The scripts in ip-up.d are
> run as root and know nothing about X and what display to put it on.  You
> will have to give xnetload an explicit -display option

i've tried adding -display :0 to the command line, and it doesn't
seem to help.

> and use xhosts or
> some other means of giving the root user on your machine permission to
> open a window on your desktop.

i run `xhost localhost' in .xsession, so that shouldn't be a
problem.

thanks though,
-- 
alisdair mcdiarmid               alisdair@letdown.demon.co.uk
[empty black dead clean cold numb free alone afraid complete]


Reply to: