[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Leased pppd LCP ConfReq trouble...

Hello, all! :)

I'm configuring leased line to my ISP. ISP has a Cisco router. When I
try to connect the pppd hangs up the line after 10 (by default) sended
LCP ConfReq packets. No other messages in /var/log/ppp.log with debug
and kdebug 7 options in /etc/ppp/options.

My system is HAMM, kernel 2.0.36, pppd 2.3.5, IPmasq. pppd works
perfectly with my diald, so I guess it's not a pppd trouble. I use
US Robotics ext. 33.600 modems. Modems work correctly (handshake, CD,
all stuff).

I decided that may be some compression relations and try to uncomment
in /options the -all and other stuff... And get the same result.

Then I try to test pppd on just Linux boxes and make fresh install on my
another box SLINK (only base install, nothing more). The same pppd, same
/options. Almost the same result. In addition, one time my dial-out box
reseives LCP-NAK packets and after reestablished handshake just ceases
to send LCP packets at all... Usual result is not receiving the LCP
packets at all... The same result on SLINK with autoanswer modem. If I
try the passive option I just get frozen pppd. And I stay on this stage.

My /etc/ppp/options:
asyncmap 0:crtscts:lock:modem:netmask
-detach (for test reason):-pap:-chap(ISP doesn't use any for leased):
debug:kdebug 7 (I don't sure it's work, but anyway):noipx

My /et/ppp/options.ttyS1:

ifconfig reports inactive ppp0 with zeros, when I run dedicated pppd.

/var/log/ppp.log <snip>:
pppd 2.3.5 started by lamb, uid 0
Using inrerface ppp0
Connect: ppp0 <--> /dev/ttyS1
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xffffbb31> <pcomp>
(doesn't matter. I try and exclude all attributes from <list> above)
last message repeated 9 times
LCP: timeout sending Config-Requests
Connection terminated.

it seems that modems don't see forein packets anyway, but I see that
packets is sent by indicators... Some clues?...


Alexey G. Khramkov

Reply to: