[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk problems

*-Darknight <Darknight@thepentagon.com>
| I downloaded 2 IRC Clients off the web to see if they were any better
| than the others i've tried.  The first one required gtk 1.1.8 i believe,
| so I blindly downloaded it from gtk.org.  This just caused more
| problems, so I uninstalled and reinstalled the GTK packages that came
| with hamm.  This did not fix the problem, so I downloaded the frozen GTK
| packages, which installed just fine, however I still get the following
| error.  This error is from the second IRC Client I downloaded, which
| requires only GTK 1.03.  Anyone with any idea how to eliminate this
| error who could help me I would be very greatful to.
|     checking for GTK - version >= 1.03... no
|     could not run GTK test program, checking why...
|     The test program failed to compile or link.  See the config.log for
| the exact error that occured.  This usually means GTK was incorrectly
| installed or that you have moved GTK since it was installed.  In the
| latter case, you may want to edit the gtk-config script:
| /usr/bin/gtk-config
|     configure: error: Cannot find GTK: Is gtk-config in path?
| gtk-config IS located in /usr/bin, and I'm not sure what it wants me to
| edit in the file.  Thank you,

You can only have one development version of libgtk installed.
This means that you'll have to chose between the stable 1.0.x
and the unstable 1.1.x. If you want to compile programs that
require 1.0 and others that require 1.1 you'll have to switch
by installing new -dev packages all the time.

You should also try to remove everything that the previous
installation may have put in /usr/local.

It will be easier to help if you post the result of executing:

dpkg -l 'libgtk*-dev' | grep ^.i

and also the last part of config.log (in the source directory where
you tried to compile).

The only way tcsh "rocks" is when the rocks are attached to its feet
in the deepest part of a very deep lake.             (Linus Torvalds)
olet@ifi.uio.no   [-: .elOle. :-]   olet@debian.org

Reply to: