[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trying to compile a new kernel.

D'jinnie wrote:

> > >  Status: cannot open '/dev/lp1' - 'Device not configured', attempt 1,
> >
> > You need to edit /etc/printcap and change lp1 to lp0. Not sure why this
> > is setup this way, do you have more than one parallel device?
> Hmm. I look at my printcap, and by default it's set to lp1.
> I shall include it for educational purproses :)
> # /etc/printcap: printer capability database. See printcap(5).
> # You can use the filter entries df, tf, cf, gf etc. for
> # your own filters. See the printcap(5) manual page for further
> # details.
> lp|Generic dot-matrix printer entry
>         :lp=/dev/lp1
>         :sd=/var/spool/lpd/lp
>         :af=/var/log/lp-acct
>         :lf=/var/log/lp-errs
>         :pl#66
>         :pw#80
>         :pc#150
>         :mx#0
>         :sh
> I haven't configured the printer on my machine yet, but I rather question
> the lp1 default...
> ---
> The chief cause of problems is solutions.
>                 -- Eric Sevareid
> jinn@irony.org
> --
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Yes I thought that lp1 as a default device "might" be the problem but it worked fine
using the 2.0.34 kernel and /dev/lp0. I did not want to mess with something that
worked before. Call me a chicken or just too cautious.  :)
But changing the lp1 to lp0  is the printcap file was the problem.  My printer works
now at least as well with the new 2.1.132 kernel as it did with the old one.

Reply to: