[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Buslogic BT-958 failing --SOLVED: BUSLOGIC firmware problem.

Buslogic is often touted as having the superior scsi adapters.
This probably has merit and Buslogic certainly works well with
the Linux community.
Without meaning to smear Buslogic, the following might tame excess
exuberance about Buslogic.
At the least, it shows a couple of their limitations.
The following solves my original entry into the debian-user mail list.

Three weeks ago I replaced an Adaptec 2940UW with your BT-958 scsi controller.
This failed on my Natoma motherboard, which came with a Dell Pentium Pro
two years ago, with messages like
    Int 13h no found.                                 
    Bios not installed.
When testing the Buslogic card (after ctrl-B on boot), I got
    "there is no Buslogic BusMaster Adapter installed."
That bothered me not, since I merely moved your BT-958 card to another
computer with an Asus P2B motherboard.

Mostly, the BT-958 card worked well.
However, unlike my Adaptec 2940UW, the BT-958 did not properly accomodate
my Exabyte 8200 8mm tape drive.
I could no longer backup my Fujitsu M2949Q disk drive onto my tape drive.
I would get errors like,
kernel: scsi : aborting command due to timeout : pid 7784, scsi0, \
                  channel 0, id 0, lun 0 Write (6) 02 34 d5 02 00
kernel: scsi0: Aborting CCB #9208 to Target 0
kernel: SCSI host 0 abort (pid 7784) timed out - resetting
kernel: SCSI bus is being reset for host 0 channel 0.
kernel: scsi0: Tagged Queuing now disabled for Target 0
kernel: scsi0: Sending Bus Device Reset CCB #9209 to Target 0
kernel: SCSI host 0 channel 0 reset (pid 7784) timed out - trying harder
kernel: SCSI bus is being reset for host 0 channel 0.
kernel: scsi0: Resetting BusLogic BT-958 due to Target 0
kernel: scsi0: *** BusLogic BT-958 Initialized Successfully ***
kernel: st0: Error with sense data: extra data not valid Current error \
                                     st09:00: sense key Unit Attention

I run Debian Linux, kernel version 2.0.34.
Leonard Zubkoff's web page 
and reference to Mylex web pages solved my problem.
I changed my BT-958 firmware from 5.07B back to 5.06J.

This problem stopped me from buying a newer Exabyte tape drive
this week, even though my problem resides in your BT-958.

This problem took me a good deal of time to solve.
Because of this problem, my computer has been in pieces for
three weeks.
Initially, I had two BT-958 adapter cards.
After some time, I realized my problem continued with just one BT-958 adapter
For a long time I thought I could solve the problem by changing the BIOS
on the BT-958 or by changing Linux kernel parameters.
Still, I thank Mylex/Buslogic for posting their web page with the solution to
my BT-958 problem, though I must admit Leonard Zubkoff's web page more clearly
told how to solve the BT-958 problem.  That solution (expanding upon Mylex's
brevity) involved getting
a DOS bootable diskette, whose creation required me to borrow a friend's 
computer a day later.
I hope a later (rather than a former) Mylex Firmware update will solve these 
BT-958 problems with Exabyte tapes.

- -- 
Jim Burt, NJ9L,		Fairfax, Virginia, USA
jameson@mnsinc.com	http://www.mnsinc.com/jameson
jameson@pressroom.com	(703) 235-5213 ext. 132  (work)

"A poor man associating with a rich man will soon be too poor 
to buy even a pair of breeches."                   --Chinese Proverb

Reply to: