[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GNOME apps error

Hi all!!

I have successfully compiled GNOME 0.20 under Debian 2.0, and now when I
start X, the IceWM window manager starts ok, but no GNOME program starts (I
mean the Panel, which is started on startup, doesn't it? And, each time I
try to start it (the panel) I get the following errors:

    error: incompatible libpng version in application and library
    All fallbacks failed

I run ldd /usr/local/bin/panel, which shows that it needs libpng.so.0 and
libpng.so.2. Then, I run ldconfig -v | grep libpng, which shows


I've used GTK 1.0.4 to compile the packages, GNOME 0.20 and Debian 2.0. Is
it a problem with library incompatibilities? But as it seems it has all the
libraries it needs. Should I upgrade to GNOME 0.30? and if so, which
packages do I need?

When I try to run any GNOME app (gnome-help-browser, gedit, gnotepad...),
they all finish by printing the following message:

    SIGSEGV caught

By the way, I use MICO instead of ORBit, but this seems ok, since as far as
I understood from the GNOME FAQ, 0.20 runs with MICO, and 0.30 does it with
ORBit. What am I doing wrong?

Thanks very much

Reply to: