[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SVGALib, Xpert@Play and sQuake/Quake II



On Sun, 20 Sep 1998, Adrian Bridgett wrote:

> Matrox Millenium isn't particularly well supported by SVGAlib at the moment.
> I have an improved patch here, but I'm a bit wary of some trimmed security
> patches which are in the upstream release  - the fewer patches we apply the
> better, however we don't want to compromise security.  Have you tried other
> SVGAlib programs.

	No, this is the only SVGAlib program I have tried. I have not had
time to try others. As for support, I just switched from a S3-968 based
Diamond card because it was not supported very well either. :( Actually,
the Matrox card came with a server I got a two months back, and it was to
be headless, so I hated for a good card to go to waste, and dropped it in
my workstation. :)

> 
> >       libm.so.5 => /lib/libm.so.5 (0x4000b000)
> >       libvga.so.1 => /usr/lib/libvga.so.1 (0x40014000)
> >       libc.so.5 => /lib/libc.so.5 (0x40051000)
> >       libc.so.6 => /lib/libc.so.6 (0x4010f000)
> >       ld-linux.so.2 => /lib/ld-linux.so.2 (0x401b4000)
> 
> Have you tried "unset LD_LIBRARY_PATH; unset LD_PRELOAD" - you may be
> forcing something nasty upon squake.

	Thought of that, and tried it, no luck.

> Wierd - the netscape wrapper script doesn't appear to do anything to the
> library loading.  "ldd /usr/lib/netscape/netscape" shows libc5 stuff only.
> 
> What are the contents of /etc/ld.so.conf? Here are mine:

	Here it is: 

/usr/X11R6/lib/Xaw3d 
/usr/lib/libc5-compat
/lib/libc5-compat 
/usr/X11R6/lib

> I agree - the dynamic loader seems to have got confused what versions of
> these packages are you using (dpkg -s package-name):
> 
> libc5 5.4.38-11 => **Mine: 5.4.38-1.1
> libc6 2.0.7t-1 => **Mine: 2.0.7r-3
> ldso  1.9.9-5 => **Mine: 1.9.9-1
> 
> I'm running slink (aka unstable) - last upgraded about a fortnight ago (two
> weeks for Americans and other non-English readers <g>) so your versions are
> likely to be a bit older.

	Yea, they are. Haven't updated as I only have a slow 28.8 line to
the net, and the school has been telling us any day they will have the
dorm LANs up and connected to the Internet. Currently it is week three or
four of that. :(

	Thanks for you help!

----------------------------------------------------------------------------
|   "For to me to live is Christ, and to die is gain."                     |
|                                            --- Philippians 1:21 (KJV)    |
----------------------------------------------------------------------------
|  Ryan Kirkpatrick  |  Boulder, Colorado  | rkirkpat@nag.cs.colorado.edu  |
----------------------------------------------------------------------------
|               http://www-ugrad.cs.colorado.edu/~rkirkpat/                |
----------------------------------------------------------------------------


Reply to: