[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: netscape 4.06 on Debian 2.0



On: Sat, 29 Aug 1998 22:38:56 -0400 (EDT) Chad Glendenin writes:
> 
> Netscape 4.06 refuses to run on my fresh Debian 2.0 system.  I
> installed the old (libc5-based) libraries that I think it needs.  I
> tried using the netscape4_4.0-12.deb package and the standard
> 'ns-install'.  Either way, Netscape is installed, but when I run it,
> all I get is an immediate segmentation fault.

Make a "ldd /usr/lib/netscape/netscape"[1] to see if there is any libc5 library
missing (you will notice when there is a libc6 based library in the
listing).  BTW: The installer should ensure that the needed libc5
based libraries are there.

> Can someone tell me what's going here and how I fix it?  I never had
> this trouble with netscape on my RedHat system.

You could install a glib2 based netscape (filename is
communicator-pro-v406-export.x86-unknown-linux2.0-glibc2.tar.gz[2]), or
install the missing (if any) libraries.

	Torsten

BTW: The version 4.06 (glib2, patched with fortify) worked quite well
     on my system, much better than 4.5b1 or the older 4.0x ones.

Footnotes: 
[1] That was the position in the netscape-3 wrapper, the 4.xx versions
I installed manually, so the position may vary.

[2] A good filename for checking the "handling of long filenames
capacity" of a file browser ;-)


Reply to: