[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Is the diskless boot possible in debian ?

Thank you VERY much for your help. I can now successfully mount my win98 partition (using
the vfat type) which makes my like sooooooooooooooooooooo much easier trying to debug the
modem problem. OK, the error is:

Jul 30 15:07:20 gunner pppd[801]: pppd 2.3.5 started by root, uid 0
Jul 30 15:07:20 gunner pppd[801]: tcgetattr: Input/output error(5)
Jul 30 15:07:21 gunner pppd[801]: Exit.

In response to your inquiry:
1) I'm almost positive I added ppp support into the kernal during setup.

2) I'm not real positive that the serial port is being initialized correctly. I think ttyS0
is being initialized (for the mouse?) but there is no evidence that ttyS1 is. I tried echo
ATDT5555555 > /dev/ttyS1 and nothing happened.

3) I'm using the same init string as I do in windows

4) This one I'm not clear on. Do I need to adduser root dip? I created a user account
(wesneski) which is the same name as my ISP account name, which I would imagine I would
have to add if I wanted to dial out as that user. But I want it to dial out as soon as
Linux boots. Is this possible? Or does each user have to dial out after they connect?

Thanks again for all your help. I really really appreciate it....

Christopher Barry wrote:

> Well firstly, what is that error in the log file? Can you be more
> specific? To read your files on the win95 partition, the command is
> mount -t msdos /dev/<windows partition device name> /mnt (can be almost
> any directory you want). For example, say you have an IDE disk and
> Windows is on your first primary partition. Type:
> $ mount -t msdos /dev/hda1 /mnt
> If during the install of Debian you added vfat support then you should
> replace 'msdos' in the above with 'vfat' so that long file names aren't
> truncated.
> One problem with your ppp attempts may be that you didn't add ppp
> support during the install of debian.
> If are looking for some communications software to test your modem, you
> can grab minicom. It's a Debian package, find it at www.debian.org.
> In general with PPP and Debian, since they made the setup so friendly
> the're only a few things that could stop you from connecting that I can
> think of.
> 1) PPP support is not built in the kernel or not loaded as a module.
> 2) Your serial port's initialization failed.
> 3) Your modem's initialization string isn't right.
> 4) Your trying to connect as a user and aren't a member of group 'dip'.
> Solution is to do: as root, type 'adduser your_user_name dip'.
> If you think Linux is hard to install, try OpenBSD (aaarrrrggghhhhhh :)
> Good luck,
> Christopher
> Christopher Wesneski wrote:
> >
> > I am having considerable trouble setting up my modem to connect to my ISP. I'm pretty
> > sure I have the serial port configured but every time I run pppd via pon I get an
> > error in the log file. I've read all the HOWTOs and anything else I can find (since
> > no one on this list will ever help you if you don't) and I am still as lost as I was
> > going in. In one of the HOWTOs they mention kermit and another program to test (not
> > connect) the modem. I only have the base installed so I need to know,
> > 1) what am I supposed to use to test that the modem is working?
> >
> > 2) is it a pert of the base install package?
> >   a) if not where can I get it and what do I need to do to get it running?
> >
> > 3) how can I mount(?) my win95 partition so I can access the files while in
> > Linux (and vice-versa)? It is a real pain to have to keep switching OSs to read this
> > lists mail and browse docs online and then try something and switch back and ......
> > well you get the picture.
> >
> > I can see why people complain about the learning curve. It's not a matter of getting
> > up it, it's just when you do get to a point where ignorance overcomes you and no one
> > is willing to help it gets very frustrating. I'm almost ready to switch back to
> > Windows (gasp) full-time.
> --
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

begin:          vcard
fn:             Chris Wesneski
n:              Wesneski;Chris
adr:            http://wwp.mirabilis.com/8555629;;;Dallas, Texas;;;USA
email;internet: wesneski@flash.net
note:           gunner@rubin.zenonline.com
x-mozilla-cpt:  ;0
x-mozilla-html: TRUE
version:        2.1
end:            vcard

Reply to: