[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Thanks for the help Jens.

I had indeed modified the X server to use xkb in order to get backspace
working properly. I edited the /usr/lib/X11/xkb/keymap/xfree86 to change
xkb_symbols from pc105 to pc101. As you pointed out pc105 was mapping my
alt keys to alt and the non-existent windows keys to meta.

Does anyone know of a better way to solve this problem? Should I have
rerun one of the X setup or config programs?

On Mon, Jul 27, 1998 at 10:25:59AM -0400, Lee Bradshaw wrote:
> Hi,
> Sometime between Saturday and Monday morning my Alt keys stopped working
> in Xemacs. I thought the only change I made was adding
>   (setq delete-key-deletes-forward t)
> however after backing out this change Alt still doesn't work. The
> Ctrl-Alt-Fx combination still works to change to a virtual terminal from
> X, so the alt key seems to be working.
> Ex. <Alt-x> prints "A-x not defined" in the minibuffer. "Esc-x" prints the
> correct "M-x".
> I tried to insert the character into a buffer with <Ctrl-q><Alt-x>. I received
> the following message in the minibuffer:
>   key read cannot be inserted in a buffer: #<keypress-event alt-x>
> Does anyone have any suggestions on debugging this problem?

Lee Bradshaw                 lee@sectionIV.com (preferred)
Alantro Communications       lee@alantro.com

Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: