[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Newbie Install - Serial port and PPP does not work

Hi All,

About a year with Linux (Slackware, Caldera) new to Debian.  Just Installed
1.3.1 (bo) CD format from Linux Mall on the same hardware that used
previous OSs.    I saw some problems during the install as the CD image was
not true to the source.  dselect complained about certain directories.  I
logged in from another virtual console to find those and gave the path to
dselect.  (non-free section is completely missing) I do not think that the
following problems are due to that but If so how do install just the PPP
part again?  Here is the problem in detail.

Serial Port/modem does not work and cannot run PPP.
when I run pon the system says kernel does not support it.  I rebuilt the
kernel with support but same problem.  I also tried Faq-O-Matic Suggestion.
I do not see the file /etc/ppp.options. So I cannot put /dev/ttyS1 instead
of /dev/modem in that file.   I have seen that some distribution put a
logical link to /dev/modem.  Will that work?  (My modem is on COM2  How do
I generate that file?

I also tried sending ATH1 to ttyS1.  (echo ATH1 > /dev/ttyS1).  I should
hear the modem picking up the line and a dial tone.     The system comes
back with I/O error message.  setserial says that port exists with correct
address.   /proc also shows the serial port.  I have also tried same ATH1
command on ttyS0 and ttyS1 ports even though  they do not exist, and it
does not work.  I have disabled on-board COM ports.  I use PS/2 bus mouse

All the hardware runs OK. This is a dual boot system with LILO.  (Other OS
is WIN95 OSR2 it uses all the hardware.)

Any help is appreciated.

Best Regards,


To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: