[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xaw-wrappers

Behan Webster wrote:
> I've tried to use the xaw-wrappers program with xload using the
> following entry in /etc/xaw-wrappers.conf:
> /usr/bin/X11/xload,/usr/X11R6/lib/libXaw95
> But all I get is:
> griffon:~> echo $PATH
> /home/verisim/usr/bin:/home/behanw/bin:/home/behanw/bin/share:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/local/games:/usr/games:/usr/share/bin:/usr/share/games:.
> griffon:~> xload
> Insecure $ENV{PATH} while running setuid at /usr/bin/X11/xload line 15.
> griffon:~> 

Is your /usr/X11R6/bin/xload a symlink to /usr/lib/xaw-wrappers/wrapper ?

I tried to reproduce this, and I can't -- I get another set of errors:

ldd: can't open /usr/X11R6/bin/xload.real (Permission denied)
xaw-wrappers: unable to determine libc version of /usr/X11R6/bin/xload.real.

What version of xaw-wrappers are you using?

This begs the question -- why on earth is xload suid on a debian system? It
doesn't need to be! I think you can just remove the suid bit from xload and
then it will work ok with xaw-wrappers.

see shy jo

E-mail the word "unsubscribe" to debian-user-request@lists.debian.org
TO UNSUBSCRIBE FROM THIS MAILING LIST. Trouble?  E-mail to listmaster@debian.org .

Reply to: