[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems w/ppp dialup and sending mail



Hi Guys....

I installed Debian 1.1 and for a year things worked quite well.  I could
send mail, receive mail via popmail, and use ppp for web access, fpt and
telnet. Except for some problems getting logged in last Christmas, which
seem to have been resolved all has been well. 

Until recently, that is, when my ISP (campus.mci.net) began bouncing
outgoing mail that has an unrecognized domain of origin. 

How in the blazes do i get a valid 'domain' I am assigned an ip number
each time I log in? 

I include typical mail message and error that I get when
attempting to send from home:


>From MAILER-DAEMON@frodo.cs.wcu.edu Sun Feb 22 15:22:30 1998
Date: Sat, 21 Feb 98 15:23 EST
From: MAILER-DAEMON@frodo.cs.wcu.edu
To: dbt@frodo
Subject: mail failed, returning to sender

|------------------------- Failed addresses follow: ---------------------|
 dorawala@cs.wcu.edu ... transport smtp: 551 Unrecognized domain
'frodo.cs.wcu.edu' 
|------------------------- Message text follows: ------------------------|
Received: by frodo.cs.wcu.edu
	id m0y1E3q-000hZ9C
	(Debian /\oo/\ Smail3.1.29.1 #29.37); Sat, 7 Feb 98 12:29 EST
Message-Id: <m0y1E3q-000hZ9C@frodo.cs.wcu.edu>
From: dbt (David B. Teague)
Subject: Ch5,6,7 notes
To: dorawala@cs.wcu.edu
Date: Sat, 7 Feb 1998 12:29:02 -0500 (EST)
X-Mailer: ELM [version 2.4 PL25 PGP2]
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
Content-Length: 10874     



I include exerpts (I hope appropriate exerpts, I hope you will tell me
if you need more): 

hosts:
127.0.0.1	localhost
152.30.5.51		frodo.cs.wcu.edu	frodo


The 152.30.5.51 is bogus at home, as is the cs.wcu.edu. It is set this
way so I can take the machine to work to connect to the net for serious
upgrades. 33K is to durned slow.  Any of this except 'frodo' is mutable.
'frodo' is my machine's name, I'd very much like to keep that. 


/etc/smail/config
 
# This is the main Smail configuration file.

visible_name=frodo.cs.wcu.edu 
-domains
hostnames=frodo.cs.wcu.edu:frodo:frodo.cs

The rest of the conf file is 'out of the box'.

I tried changing the host name, the mailer still picks up the
visible name here or some other place, and mci bounces the mail.

For example
	hostnames=wcu.campus.mci.net

gets me nothing. 

I tried several variations on settings of hosts and host naes in config
files, but I do not seem to be able to get mci to allow me to send mail
with any domain name I can guess. 

I have appended the headers from an earlier successful mail message sent
from home to a machine at work in hope that some knowledgable person can
see what this ISP requires. 

Help, please!

--David   (teague@wcu.edu, dbt@elentari.cs.wcu.edu)



Appendix: Full headers from an ealier message successfully
sent 2 Dec 1997:

Received: from aus-e.mp.campus.mci.net (aus-e.mp.campus.mci.net
[208.140.84.25]) 
	by elentari.cs.wcu.edu (8.8.5/8.8.5) with ESMTP id LAA23910
	for <dbt@elentari.cs.wcu.edu>; Tue, 2 Dec 1997 11:32:05 -0500
Received: from frodo.cs.wcu.edu (root@s12-pm24.snaustel.campus.mci.net
[208.140.81.233]) 
	by aus-e.mp.campus.mci.net (8.8.8/8.8.8) with SMTP id LAA11107;
	Tue, 2 Dec 1997 11:23:57 -0500 (EST)
Received: by frodo.cs.wcu.edu
	id m0xcv26-000hZ9C
	(Debian /\oo/\ Smail3.1.29.1 #29.37); Tue, 2 Dec 97 11:18 EST
Message-Id: <m0xcv26-000hZ9C@frodo.cs.wcu.edu>
From: dbt@frodo.cs.wcu.edu (David B. Teague)
Subject: Exercises on subsitution and Translation
To: jkillen@cs.wcu.edu, mummert@cs.wcu.edu, dbt@elentari.cs.wcu.edu
Date: Tue, 2 Dec 1997 11:18:46 -0500 (EST)
X-Mailer: ELM [version 2.4 PL25 PGP2]
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit







--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: