[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with dual boot NT/linux


    I came accross a big problem when I tried to install Debian linux :
I can't boot anymore NT nor DOS on my hardrive...

Here was my config before i tried to install:

PC pentium-pro 150 MHz with 2 HD and three OS : dos nt Slackware 3.3
/dev/sda1   boot  dos partition 400Mo
                  with dos installed on c:\dos
/dev/sda2         extended partition
/dev/sda3         swap partition 89Mo (for linux)
/dev/sda5         ntfs partition 1500mo
                  with NT 4.0 installed d:\winnt
/dev/sdb1         ext2fs partition 1Go (with linux)

I was using the NT boot loader which was installed on c: (/dev/sda1) and
which was giving me three choices :
1) NT on d:\winnt (/dev/sda5)
2) DOS on c:\dos (/dev/sda1)
3) linux on /dev/sdb1 via the file c:\linux.bin

The only bootable partition is /dev/sda1.
Lilo was installed on the first superblock of /dev/sdb1.

At this point I tried to install Debian 2.0 with floppies (but the
install menu said it was Debian 1.3 ...).
Everything was OK until I reached the base 3 floppy which was apparently
corrupted. So I decided to re-boot NT in order to make a new sane floppy
but I can't : the computer says me :
"Missing operating system"

First I thought that it was just because Debian has somehow installed
something on the master boot record, so I booted dos with dos system
floppy and I did "fdisk /MBR" in order to clear the MBR and I verified
that my dos partion was OK; but I didn't work out. I also tried to
remove the second hard-drive (/dev/sdb) but it still tells me :
"Missing operationg system"

Well I really don't understand because I've installed slackware many
times without any problem.
I hope I was not too boring and that someone may help me because I'm
lost and by now I couldn't do anything at all.

Thanks in advance for any help.



TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: