[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: can't install buzz!

On Mon, 19 Jan 1998, Hamish Moffatt wrote:

> I don't suppose anyone here is feeling nostalgic and can think of
> any reason why the buzz (1.1) boot disk would hang on me? Kernel 2.0.0.
> I get "eata_dma: no BIOS32, still needed" etc, then it hangs. This
> is sometimes caused by NE2000 cards being probed, but I pulled mine
> out completely and it still happens. I've left it for about 20 minutes
> now and it hasn't changed.
> I remember that APM was a problem but it's disable as it can be in
> the BIOS. I don't understand why this kernel is compiled with APM
> support in if APM doesn't work properly, but still. It seems
> to get passed that anyway.
> Any ideas? I want to install buzz to test the auto-upgrade.
> Might have to use rex disks. All the hardware I have is an IDE
> hard drive, a floppy drive, an ISA IDE controller, a Trident 8900CL
> video card, and a 486DX2-66 overdrive chip, and 16mb RAM.
> It doesn't seem to be crashing because of some hardware fault,
> just a bad kernel probe.

When testing bo when it was frozen, I encountered similar problems with a
486dx40 with 8 MB ram, a vesa-localbus Trident 9000, vesa-localbus ide
interface + ide drive, a ne2000 and a matsushita cdrom interface + cdrom.

IIRC it hung while the md driver was probing, but that's how I remember
it, not how I understand it (I don't.) It's likely something that has to
do with a vesa-localbus ide interface. Here at work I have a 486dx66 with
a scsi interface + drive, no ide at all and the bo bootdisk worked just

I solved the problem by building a customized kernel and copying that onto
the resc1440.bin disk (don't forget to compile initrd in and to set the
root disk to ramdisk.) After that I had no more problems.



P.S.: I managed to solve another vesa-localbus-related problem last week:
since moving to libc6 I was getting lots of segfaults and on the console
errors showed: "free_one_pwd: bad directory entry" or something.
It turned out that the xserver for my mach32 videocard was using a wrong
aperture setting. Since fixing this with a line "MemBase 0x02000000" in
/etc/X11/XF86Config, all problems have evaporated. 

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: