[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dselect thru SOCKS4 firewall

Stephen P. Serafin wrote:
> >As you know, using the 'runsocks' script is supposed to enable
> >any application to run using socks. I never was able to get this running
> >with socks4 though. You can, however, use the socks5 package. The
> >socks5 libraries are quite able to interact with a socks4 server so
> >you don't need to change the server. You'll have to download the
> >socks5 source from NEC and compile it. Then just set up your config
> >files and everything should work. If you need any help getting
> >this set up you can ask me. Once everything is compiled, installed
> >and configured you should be able to use 'runsocks dselect'. Make
> >sure that when you choose the ftp method that 'passive mode' is
> >enabled.
> Thanks for responding to my problem.  I tried a few things last night
> and thought you might like an update.
> runsocks did not come with the socks4-clients package.  What it does
> seems pretty simple though, it overrides libc library functions with
> its own through the dynamic linker.  So I decided to try this with the
> socks4 library.  I did this by setting the LD_PRELOAD=libsocks.so.4.3
> environment variable.  Unfortunately all commands stopped working.
> I think the problem is that most of my system is libc5 but socks4 is
> libc6.  Maybe if my whole system were libc6 it would work.  There seems
> to be quite a difference between the two.
> Next I tried to compile socks5.  configure reported that dynamic
> libraries were not supported on my system though.  Again I think it
> is because of libc5 and libc6 issues.
> One of my major reasons for getting dselect to work is so I can load
> a purely GNU libc 2.0 system.  I may end up doing this in stages
> before I can use dselect through the socks server.

Ah, this is why you're having the problem. You see, the LD_PRELOAD
stuff "preemtps" the bindings to the C shared library. If you want
this to work for libc5 programs, you *must* compile your socks shared
library with libc5. This is because your socks library itself uses
libc and it has to be the same libc that the program uses. 

Now as I said before, the "runsocks" from the socks4 package never
worked for me. OK, there may not have been a "runsocks" script
with socks4 but doing LD_PRELOAD is effectively the same thing. It
never worked for me. If it works for you, I'd love to hear the 
success story. I'd say go to the socks5 package. I've found the
server (at least under Linux) to be more stable anyway and socks5
supports some nice features. In other words, someday you'll want to
upgrade and when you do you'll already have the library.

Anyway, good luck. Let me know how things go.

Jens B. Jorgensen

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: