[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

HELP! Broke X, vi

Cheerfully trying to edit a new file, I got into the help minibuffer to
find out an Xemacs command. I tried loading a file, and got an error
message. I moved to the *scratch* buffer, but that turned out to be the
help minibuffer also. I then kept deleting buffers until Xemacs died, with
a core dump. It asked me to use gdb on the core and email the output to
the bug-fixers. Because I had a text file called 'core' at one stage, I
ran vi on it figuring if it was a real core file I'd just see a whole lot
of gibberish. However vi died, and the xterm became unusable. After that,
vi died once incepted thereafter. 

 I tried rebooting the system, and startx resulted in the normal windows
and programs (just two xterms and swisswatch) but with white borders and
no Fvwm widgets. Moving the mouse changes the focus, but the mouse buttons
no longer function, consquently I can't move the windows or get the Fvwm
menu up to quit the program. Killing it with 'kill' resulted in being
unable to restart X, so I rebooted again. I found X, Fvwm and vi work fine
with root. Aha! I thought. I'll just add another user and use that until I
get things fixed. However the new user had the same problems as my orginal
user id. 

What do I do now? 

 Andrew Tarr 


 "Some say love makes the world go around, others say it's money. Actually, it's angular momentum"
   -Dave Frame 

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: