[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't login anymore

Thanks Oliver. You nailed it.
I had forced install of libreadlineg2, libc6 and a bunch of other stuff postgresql 6.2.1 was complaining about that it needed. Boy! am I sorry I did that.
What a mess. My dotmatrix
printer now prints a line a minute. Still can't figure that one out. Fixed startx.
Anyway you mentioned changing /bin/bash to some other shell. I tried csh and it made it possible to login. But when I tried to run some scripts I got
segmentation fault.
So I reinstalled libreadline2 from cdrom. Booted and I get my usuual login prompt.

Now maybe you can help. How do I get libreadling2 to install. With it I can run the
progres psql. Without it I get a buzzing sound until I control-C.

I think I still have libc6 in there. But maybe that's  why am having trouble with printing.

Also can you tell me what version of progres you run .

Incidently I sent you a message a few days before I got into this jam.
To olly@lfix.co.uk and pointed out to you that the URL in your signature is broken.



Oliver Elphick wrote:

> Chuma Agbodike wrote:
>   >Right after I installed postgres 6.2.1 and played with is a little I
>   >can't log into my LINUX anymore. Everything goes on as usual until it
>   >reaches:
>   >INIT: entering runlevel: 2
>   >Then it differs from what it used to do, which is start the various
>   >daemons
>   >Now it says: Debian Linux 1.3 (none) tty1
>   >(none) ?????     That's not what it used to say.
>   >
>   >(none) login:
>   >
>   >No matter how I login : even as root it takes me back to (none) login:
>   >
>   >If I try <ctrl><alt><del> it loops also on the following:
>   >
>   >"Give root password for maintenance"
>   >(or type Control-D for normal startup):
>   >
>   >Only way out is a hard reset
>   >
>   >Please help. If there is any way rather than reinstall.
> You need to find what in particular is broken.  Boot from your floppy or
> CD and investigate.
> The login prompt is started by getty, which then calls login, which then
> starts a shell. /etc/init.d/rc is a bash shellscript as well, and bash is
> what you would get into from the single-user login; so it looks as if your
> bash has been damaged, or perhaps a shared library that bash needs:
> $ ldd /bin/bash
>         libreadline.so.2 => /lib/libreadline.so.2 (0x40011000)
>         libncurses.so.3.4 => /lib/libncurses.so.3.4 (0x40033000)
>         libdl.so.2 => /lib/libdl.so.2 (0x40078000)
>         libc.so.6 => /lib/libc.so.6 (0x4007b000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
> Try booting from a floppy/CD and putting /bin/ash (or whatever other shell you have that doesn't depend on an unmounted file-system) in the shell field of
> the password entry (make sure you edit the one on your hard disk, rather than
> on the ramdisk.)
> Incidentally, I have installed postgresql a number of times with no problem.
> --
> Oliver Elphick                                Oliver.Elphick@lfix.co.uk
> Isle of Wight                                  http://lfix.co.uk/oliver
> PGP key from public servers; key ID 32B8FAA1

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: