[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: is the Creative Labs AWE64 GOLD Soundcard supported?

On Wed, Oct 22, 1997 at 03:59:54PM -0200, Nicola Bernardelli wrote:
> > > >      As you suggested (THANK YOU), Marcus, I got 0.4.2c and it correctly
> > > > detects size of memory on soundcard: 
> > > > 
> > > > AWE32-0.4.2c (RAM4096k)
> > > > 
> > > 
> > > I tried installing it on top of the AWE support coming with kernel
> > > 2.1.55... it works! (So far I tried with pnp handled by isapnp and not by
> > > the kernel, but will try that too.) 
> > 
> > 
> > PNP handled by the kernel doesn't work. Anyway redoing it with isapnp
> > succeeds, not that anything is stuck unreacheable.  
> > 
> > I've just ftp'ed and applied the small :-) patch files bringing from
> > 2.1.55 to 2.1.59, pub/Linux/kernel/v2.1/patch-2.1.5[6-9].gz on a mirror
> > of sunsite.unc.edu, less than 200k total. Good that I didn't rm that big
> > linux-2.1.55.tar.gz! _Tomorrow_ I will configure 2.1.59, build and test
> > PNP and use 2.1.59 to continue looking at SLab.
> As with 2.1.55, 2.1.59 PNP handling does not initialize properly the AWE64
> Gold, nothing works, not only awe synth but also /dev/audio. Again,
> running isapnp both during boot or after boot_with_kernel_PNP_"mis-handle" 
> results in anything working fine. Anyway I recompiled 2.1.59 without PNP
> (is it possible that the two zImage files have the same _identical_
> size?!). I installed the 0.4.2c awe driver on top of 2.1.59, of course.

Ok, I understand.

> Before reporting to the kernel mailing list the PNP problem I'll look for
> docs on PNP handling done by the kernel, maybe some config file is needed
> as well...? I read _nothing_ on the matter as that wasn't my main goal. 
> (I could also try putting an #error directive in some PNP .c file and see
> whether that goes compiled or not.) 

Ok. Please mail me about PnP if you have new information. I will try the new
kernels for myslf some time (far away from now, I suppose... lot to do).

> On Wed, 22 Oct 1997, Nicola Bernardelli wrote:
> >     BTW2: I am just testing 2.0.30 last rebuild, I had to see some
> >     OSS/xmixer relations, and while writing this message I was also
> >     zcatting a 2552707 bytes .gz file to less -i doing a pattern search in
> >     it... and suddenly this error line started to appear 6-7 times per
> >     second on any console I went to look at: "Unable to load interpreter".
> >     Typing ctrl-c where the zcat ... | less -i processes had been started
> >     allowed recover, and I'm finishing this message and going to send
> >     it without rebooting (but good that you suggested to switch back my
> >     default to 2.0.29 as the latest stable kernel). 

Huh? I missed this prior. Perhaps less is not the right thing to do with a
gzipped file this big... although it should work. Strange!
> 2.1.59 has that "problem" too, 2.0.29 too... it is just "out of memory" 
> (I recently reduced swap partition from 33Mb to 8Mb as it nearly never
> worked - 32 Mb ram BTW - and when it worked it was 2-3 megs and I needed
> to collect disk space), better run zgrep on that high-compression-ratio
> .gz file or almost :-) not load at the same time the debian-user mail
> folder (currently it is very big and is soon going to become another
> gzipped month-or-little-more debian-upTo97mmdd.gz file). 

8MB swap is far to low, if you ask me. Although you have 32 MB, if you run
out of memory, it can break you suddenly, and important work can be at loss.

What is your mail reader?
Thank you,

"Rhubarb is no Egyptian god."
Marcus Brinkmann

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: