[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: is the Creative Labs AWE64 GOLD Soundcard supported?

On Mon, 20 Oct 1997, Nicola Bernardelli wrote:

>      As you suggested (THANK YOU), Marcus, I got 0.4.2c and it correctly
> detects size of memory on soundcard: 
> AWE32-0.4.2c (RAM4096k)

I tried installing it on top of the AWE support coming with kernel
2.1.55... it works! (So far I tried with pnp handled by isapnp and not by
the kernel, but will try that too.) 

Why did I retake up 2.1.55? Because I had it handy here... 
    (I'm too tired these days to wake up at 4-5 and watch a 3 hours ftp to
    get 2.1.57 or newer [?]... hard life in Italy with our monopolist
    telephone company! Great hopes for next years.)  
... to test SLab with it.

I understand from SLab doc release.notes that it needs "OSS/Free (nee:
VoxWare) drivers reved to something like 3.5.X.", and this is what the AWE
install.sh script reports when fired...
              ...on 2.0.29 and 2.0.30             ...on 2.1.55
AWE 0.3.3e   "OSS/Free-3.5.0 (aka USS/Lite)"     "OSS/Free-3.8b5 or newer"
AWE 0.4.2c   "USS"                               "OSS-3.8b5 or newer"

(Where does it get it? SOUND_INTERNAL_VERSION is defined in the kernel
header file /usr/src/linux/drivers/sound/soundvers.h, and the awe driver
install.sh script translates it in what it needs, which is not the mere
SOUND_VERSION_STRING also defined in that header.) 

BTW: SLab starts quite fine now, the error message about SHMEM was
misdirecting investigation toward that point, but instead it was an
absolutely trivial environment problem, I attach a tiny patch for the
startup script not to be error prone in case of SLAB_HOME different than
the default, if anybody is interested (but I'm currently using another
script which eventually stops the Network Audio System before starting
SLab and restarts it after SLab exits, running on sh instead of csh just
because I'm not familiar to the latter). I'm also writing anything I find
in a report I'll mail to the author when I'm sure of the contents. I have
_just_ started trying with it and with the sound driver coming with 2.1.55
somethings seems to happen. 

    BTW2: I am just testing 2.0.30 last rebuild, I had to see some
    OSS/xmixer relations, and while writing this message I was also
    zcatting a 2552707 bytes .gz file to less -i doing a pattern search in
    it... and suddenly this error line started to appear 6-7 times per
    second on any console I went to look at: "Unable to load interpreter".
    Typing ctrl-c where the zcat ... | less -i processes had been started
    allowed recover, and I'm finishing this message and going to send
    it without rebooting (but good that you suggested to switch back my
    default to 2.0.29 as the latest stable kernel). 


xmixer: a channel with an ear icon appears when fired under 2.1.55, not
clear to me what that is (microphone monitoring volume?) and what the
igain/ogain (also appearing under 2.0.29 and 2.0.30) are when compared to
each source volume and to the master volume and to the ear cursor itself
(the Creative Mixer doesn't have any of these ear/igain/ogain...). 

Marcus, alas I hadn't time to look at all those other mixers you mentioned
yet, so far I only saw those two, xmix and xmixer. 

I am _very_ tired. Too may times went to sleep at 2-4 in the morning. 

     Nicola Bernardelli <nbern@mail.protos.it>
     Please use <n.bern@mail.protos.it> for messages from any kind of
robot, such as mailing lists. From that address no autoresponse
messages will come, even when I am away for some days.
--- startSLab.orig	Sat May  3 18:14:48 1997
+++ startSLab	Tue Oct 21 09:49:38 1997
@@ -7,7 +7,7 @@
 setenv TCL_LIBRARY ${SLAB_HOME}/tcl.files
 setenv TK_LIBRARY ${SLAB_HOME}/tcl.files
-set path = ( /usr/slab/bin /usr/slab/effects $path )
+set path = ( ${SLAB_HOME}/bin ${SLAB_HOME}/effects $path )
 exec mixslab | & cat > /dev/null

Reply to: