[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wierd crankiness

I am having wierd things happen to my machine.  Any help with
these problems I would be greatful.  I suspect they're related
problems, as they all happened at once...

1) login and passwd do not work!!
   If a user has a passwd, login always fails (Login incorrect) but
   never asks for a password.
   If I do "passwd", I get:
       Changing password for darin
       Enter the new password (minimum of 5, maximum of 8 characters)
       Please use a combination of upper and lower case letters and numbers.
       The password for darin is unchanged.
   But it never gives me a chance to type anything in!
   This is most peculiar, as "ldd passwd" shows it only uses libc.so.5,
   but I've tried both libc5-5.4.33-7 and 5.4.33-3.

   These lines are in /var/log/auth.log, probably from a remote
   samba connection.  When trying to login normally, auth.log
   just says "invalid password", even though one was never asked for.

    pam[214]: (other) illegal module type: OTHER
    pam[214]: (other) illegal control flag: auth
    pam[214]: unable to dlopen(/usr/lib/security/required)
    pam[214]: [dlerror: File not found]
    pam[214]: adding faulty module: /usr/lib/security/required
    pam[214]: (other) illegal module type: OTHER
    pam[214]: (other) illegal control flag: account
    pam[214]: (other) illegal module type: OTHER
    pam[214]: (other) illegal control flag: password
    pam[214]: (other) illegal module type: OTHER
    pam[214]: (other) illegal control flag: session

   (oddly, ftp.debian.org doesn't seem to have source for passwd and login,
   so I can't debug them to find out where it's failing)

2) Things don't unmount cleanly when rebooting.  I do have autofs running,
   maybe this is the new thing that is messing it up.
   Is there any way to tell why something won't mount or is busy?
   (I tried umount /usr, and it always tells me it's busy, but I'm in
   single user mode, "mount" shows it unused, etc)

3) When mounting from an NFS toaster, I get the errors:
   Portmap: RPC call returned error 111
   RPC: task of released request still queued
   RPC: (task is on xprt_pending)

4) Don't know if it's good or bad, but I get error counts when I do
   "ifconfig".  *Even* for "lo", which should never have errors.  Is
   this normal, or sign of a problem:
    lo        Link encap:Local Loopback  
              inet addr:  Bcast:  Mask:
              UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
              RX packets:1173 errors:14 dropped:0 overruns:0
              TX packets:0 errors:1173 dropped:14 overruns:0

    eth0      Link encap:10Mbps Ethernet  HWaddr 00:60:8C:BE:CA:B5
              inet addr:  Bcast:  Mask:
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7690078 errors:37241 dropped:0 overruns:0
              TX packets:0 errors:524636 dropped:5581 overruns:0
              Interrupt:10 Base address:0x300 

Here's what I did before things started crashing
- I may have done a dselect a week or so ago but never rebooted.  I thought
  I rebooted, but...
- I started setting up autofs, to use instead of amd.  I had problems with
  autofs starting, as it kept thinking its mount points were already busy.
  So I rebooted
- The reboot failed miserably; turns out that the netbase-3.00 wasn't working
  (ldconfig eth0 was giving errors)
- Downgrading to netbase-2.13-1 fixed the network problems and I could log in.
- Autofs seemed ok, so I uninstalled amd.
- Shortly after this, logins stopped working.  This happened while still
  logged in on one virtual console.

Darin Johnson

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: