[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrading old RH4 system to Debian 1.3.0

I thought it might be a good idea (which is usually the bad idea(tm))
to upgrade old RedHat4 system to Debian 1.3.0. So, this is a
production machine, so I thought complete install is out of question
and preferred method would be libc-upgrade and then proc-by-proc
installation to make sure machine is usable all the time.

Happily compiled statically linked dpkg and copied needed files to RH
system. Ok, everything seems to be working (as always), but dpkg-deb
fails with following error:

gzip: stdout: Broken pipe
dpkg-deb: subprocess gzip -dc returned error exit status 1

So, compiled statically linked gzip (just in case libc-5.4.33 isn't
working ok with old RH4 binaries), tar and cpio. Still getting same errors.

Has anyone solution for this (except doing complete install, which
isn't really an option here)?

Sami Laine
		To reply via mail, remove 'no.spam.' from my address.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: