[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XF86Setup trouble



For some odd reason I can configure X w/o an existing config file and
cannot when one exists.  I've included the configuration made by XF86Setup
and the output below after running setup for the second time.

XF86Config: /etc/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: Microsoft, device: /dev/mouse, baudrate: 1200,
       Chorded middle button
(**) Accel: Graphics device ID: "Primary Card"
(**) Accel: Monitor ID: "Primary Monitor"
(**) MONO: Graphics device ID: "Primary Card"
(**) MONO: Monitor ID: "Primary Monitor"

Fatal server error:
No "Display" subsection for -bpp depth 8

any ideas?  the configuration file looks normal to me.

-Paul
# XF86Config auto-generated by XF86Setup
#
# Copyright (c) 1996 by The XFree86 Project, Inc.

#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
# to deal in the Software without restriction, including without limitation
# the rights to use, copy, modify, merge, publish, distribute, sublicense,
# and/or sell copies of the Software, and to permit persons to whom the
# Software is furnished to do so, subject to the following conditions:
#
# The above copyright notice and this permission notice shall be included in
# all copies or substantial portions of the Software.
#
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
# THE XFREE86 PROJECT BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
# OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
#
# Except as contained in this notice, the name of the XFree86 Project shall
# not be used in advertising or otherwise to promote the sale, use or other
# dealings in this Software without prior written authorization from the
# XFree86 Project.
#

# See 'man XF86Config' for info on the format of this file

Section "Files"
   RgbPath    "/usr/X11R6/lib/X11/rgb"
   FontPath   "/usr/X11R6/lib/X11/fonts/misc:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/Type1"
   FontPath   "/usr/X11R6/lib/X11/fonts/Speedo"
   FontPath   "/usr/X11R6/lib/X11/fonts/misc"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi"
EndSection

Section "ServerFlags"
EndSection

Section "Keyboard"
   Protocol        "Standard"
   XkbRules        "xfree86"
   XkbModel        "pc101"
   XkbLayout       "us"
EndSection

Section "Pointer"
   Protocol        "Microsoft"
   Device          "/dev/mouse"
   BaudRate        1200
   ChordMiddle
EndSection

Section "Monitor"
   Identifier      "Primary Monitor"
   VendorName      "Unknown"
   ModelName       "Unknown"
   HorizSync       31.5-48.5
   VertRefresh     55-90
   Modeline  "1152x864"   65.00 1152 1168 1384 1480 864 865 875 985 interlace
   Modeline  "1024x768"   65.00 1024 1032 1176 1344 768 771 777 806 -hsync -vsync
   Modeline  "800x600"    50.00 800 856 976 1040 600 637 643 666 +hsync +vsync
   Modeline  "640x480"    36.00 640 696 752 832 480 481 484 509 -hsync -vsync
   Modeline  "640x400"    31.50 640 672 736 832 400 401 404 445 -hsync +vsync
   Modeline  "512x384"    22.00 512 528 592 640 384 385 388 404 -hsync -vsync
   Modeline  "480x300"    29.95 480 504 584 624 300 319 322 333 doublescan
   Modeline  "400x300"    25.00 400 424 488 520 300 319 322 333 doublescan
   Modeline  "320x240"    15.75 320 336 384 400 240 244 246 262 doublescan
   Modeline  "320x200"    12.59 320 336 384 400 200 204 205 225 doublescan
EndSection

Section "Device"
   Identifier      "Primary Card"
   VendorName      "Unknown"
   BoardName       "Diamond Stealth 64 Video VRAM (TI RAMDAC)"
   #Option "slow_vram"
   #DacSpeed 220
# Use Option "nolinear" if the server doesn't start up correctly
# (this avoids the linear framebuffer probe). If that fails try
# option "nomemaccess".
#
# Refer to /usr/X11R6/lib/doc/README.S3, and the XF86_S3 man page.


EndSection

Section "Screen"
   Driver          "Accel"
   Device          "Primary Card"
   Monitor         "Primary Monitor"
   SubSection "Display"
      Depth        8
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        15
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        16
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        24
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        32
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
EndSection

Section "Screen"
   Driver          "Mono"
   Device          "Primary Card"
   Monitor         "Primary Monitor"
   SubSection "Display"
      Depth        1
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
EndSection

Section "Screen"
   Driver          "VGA2"
   Device          "Primary Card"
   Monitor         "Primary Monitor"
   SubSection "Display"
      Depth        1
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
EndSection

Section "Screen"
   Driver          "VGA16"
   Device          "Primary Card"
   Monitor         "Primary Monitor"
   SubSection "Display"
      Depth        4
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
EndSection

Section "Screen"
   Driver          "SVGA"
   Device          "Primary Card"
   Monitor         "Primary Monitor"
   SubSection "Display"
      Depth        8
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        15
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        16
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        24
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
   SubSection "Display"
      Depth        32
      Modes        "1152x864" "1024x768" "800x600" "640x480" "640x400" "512x384" "480x300" "400x300" "320x240" "320x200"
   EndSubSection
EndSection

Reply to: