[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing twin and other questions



In article <Pine.LNX.3.96.970927170502.2357A-100000@boley.escape.com> tmalloy wrote:
: I know someone asked about this recently.  Sorry for not paying more
: attention.  I got twin from the caldera archive.  It does not seem to have
: compiled correctly.  Can anyone tell me how they got it up and running?  I
: am trying to install it to /twin because I have a lot of room on /.  I
: know that it is hard to tell what the problem I am having is. Is it
: appropriate to attach a script file of the compile?  If it is I can do
: that.

That's ok, I think. However you might want to look at the mailing list
archives at www.debian.org. Select "Support" and then "mailing list
archives".

:  I try to do almost everything except administration as user.  I only
: proform administration such as installing all debian stuff as root.  Is it

Good.

: safe to install/compile non-debian programs as root.  I tried to install

In the most general sense, no. You have to go through the code to see
it doesn't do things you don't want to happen.

In the case of twin, I'd think it'd be safer. They obviously don't
want to wreck you system. But there might be bugs that might, but
that's the same for all code.

For compiling debian packages I don't think you need to be root, except
for a very limited set. For libraries it ought to go well to compile
them as non-root and then install them as root.

: twin as both and neither worked well.  Why is it that certain programs do
: not execute as root even though x permission is set. (xboard for example)
: I am not advocating playing chess as root I would just like to understand
: the mechanics involved.

Because the s bit isn't set, cf.:
descartes:~> ls -la /usr/games/xboard /usr/bin/at
-rwsr-xr-x   1 root     root        31836 Jun 17 18:05 /usr/bin/at
-rwxr-xr-x   1 root     root       283280 Jan 16  1997 /usr/games/xboard
   ^
   Here!

:  And lastly, like most all of you I love poking around my system.  I have
: no objection to having to fiddle around a little in order to make things
: work. In fact I love it.  This is one of the charms of linux and something
: will be lost when or if it becomes a fully polished product.  However
: having said that, it really annoys me when I cannot try an application
: deselect says I have installed because I cannot figure out what the name
: of the executable is. Many new linux users are not coming with strong unix
: backrounds. And may in fact know little or nothing about the program
: they are trying out or learning.  Please keep this in mind. At least let
: us know how to start the application.  Anyway dselect says visual-tcl is
: installed, but where is it?

I don't know anything about visual-tcl, but you could try "man -k
visual-tcl" and if that doesn't give any hints "man -k tcl". And you
could look in /usr/doc to see if there's a directory named something
like tcl.


Right,

							MartinS


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: