[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [ 0.84 Debian compile ?]

> Has anyone been able to successfully compile 0.84 using the Debian GNU/Linux
> distribution.  I have installed all legal combinations of gcc, cpp, bin86.
> binutils, libc5 and libc6 with no success.  "configure" is successfull with
> no problems.  "make install" gives the following error message no matter
> which versions of packages are installed:
> mutt-0.84# make install
> gcc -Wall -pedantic -g -O2 -DSHAREDIR=\"/usr/local/lib\" -I. -I. -I./rx
> -c addrbook.c -o addrbook.o
> In file included from mutt.h:518,
>                  from addrbook.c:19:
> protos.h:244: conflicting types for ys_errlist'
> /usr/include/stdio.h:219: previous declaration of ys_errlist'

Have you tried to apply the debian patches for mutt_0.81 to
mutt-0.84? Maybe the problem existed before 0.84, and the
maintainer fixed it. (And, you could also have a look in
the debian/rules file, to see if anything special happens
in the "build" target).

joost witteveen, joostje@debian.org
#!/usr/bin/perl -sp0777i<X+d*lMLa^*lN%0]dsXx++lMlN/dsM0<j]dsj
$/=unpack('H*',$_);$_=`echo 16dio\U$k"SK$/SM$n\EsN0p[lN*1
#what's this? see http://www.dcs.ex.ac.uk/~aba/rsa/

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org .
Trouble?  e-mail to templin@bucknell.edu .

Reply to: