[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ppp loopback

Hi all

and thanks to Dimitri and Bruce Perens who showed me the way ..

> >> Apr  1 21:05:52 zanzy pppd[351]: Serial line is looped back.
> ...
> >What does this mean?(*) What can I do to prevent it?
> Usually happens when
> a) you forgot to send "ppp" command to your ISP (ie. common
> login sequence is to to send username, password and then "type of
> service -- ppp, slip, whatever)

This is not the case, since, as I said, the same script with same hw works
fine .. but it's Slackware, and I want to get rid of it and move completely to

> b) ppp takes long time to start on your ISP's box.

This is probably the cause, but still I don't see why .. except Slack pppd being
slower than debian pppd .. so not catching up with my ISP.
Reading Debian doc about pppd (/usr/doc/pppd/README) suggest me to put a

chat <chat script> && sleep 5

in my script and this fixed it. But .. it doesn't start ip-up properly, since
ip-up does the following:

# $Id: ip-up,v 1.1 1996/01/31 21:25:59 alvar Exp $
# This script is run by the pppd after the link is established.
# It should be used to add routes, set IP address, run the mailq 
# etc.
# This script is called with the following arguments:
#    Arg  Name               Example
#    $1   Interface name     ppp0
#    $2   The tty            ttyS1
#    $3   The link speed     38400
#    $4   Local IP number
#    $5   Peer  IP number

# The  environment is cleared before executing this script
# so the path must be reset
export PATH

# MK @ PC 96/01/25

# say we're on-line
echo "running on $1 to $5 as $4 @ $3" > /dev/console


# routing
route del default 
route add default dev ppp0

# send mail
echo 'doing putmail' > /dev/console

# get mail
echo 'doing getmail' > /dev/console

echo "ip-up done!" > /dev/console

# last line

and I get messages from the echo lines, but I don't get any mail popped or sent.
Strange is, if I run ip-up by hand, it behaves properly.
Also, in debian pppd I have to set default route by hand, since pppd informs me
that he refuses to substitute my default route (usually to eth0) to ppp0
I'm using defaultroute in options file, but this doesn't help.

I'm not complaining, when I compare slackware to debian. In all machine I have
installed (up to now, more than 10) debian behaves generally better than Slack,
so I'm happily moving all machine to debian. I just want to know what I'm doing
wrong here, since probably it's my fault. Thanks to all the folks who made and
still make debian so good!

Any help is welcome
Thanks in advance

> b) use "TIMEOUT" chat commands, "passive" or "silent" pppd options.

I'll try them

||    || |||||||  Marco Frattola                     Microsoft is not the answer
||`..'|| |||...   Piacenza, Italy                    Microsoft is the question
|||  ||| |||''    mfrattola@mail.enjoy.it            "No" is the answer
|||  ||| |||      www.enjoy.it/users/~mk/index.html  Live Linux, live free!

Reply to: