[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Q: ldso_1.8.10-1_i386.deb

On Feb 20, David Puryear wrote
> When I do dpkg -i ldso_1.8.10-1_i386.deb here is what I get:
> (Reading database ... 18262 files and directories currently installed.)
> Preparing to replace ldso 1.8.5-1 (using ldso_1.8.10-1_i386.deb) ...
> Unpacking replacement ldso ...
> Setting up ldso (1.8.10-1) ...
> ldconfig: warning: can't open /usr/lib/libc.so (No such file or
> directory), skipping
> ...
> I didn't have these warnings when I installed ldso_1.8.5-1_i386.deb
> Is this ldso problem or is it other packages not being upto-date?

You probably have mismatched run-time and development packages.  For
example, your libc package might be at version 5.4.23 while your
libc-dev package is still at version 5.4.20-1.  The version numbers
are supposed to match exactly.  Dpkg is supposed to prevent this from
happening but doesn't always seem to do it.

David Engel                        ODS Networks
david@sw.ods.com                   1001 E. Arapaho Road
(972) 234-6400                     Richardson, TX  75081

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: