[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: help with dselect

On Thu, 20 Feb 1997, Mikael Hallendal wrote:

> Today I connected to ftp.debian.org with dselect to see if there was
> any new packages. It was and among them there was a new version of
> sysklogd. Now the dependences for this one states that it depends
> on bash (<<2.0.1). When using ftp I have chosen [unstable contrib
> non-free] for my FTP-selections, this means that the only available
> bash is 2.0.2 with is >2.0.1
> Now my question. Is there a way to tell dselect not to try installing
> this new version, not using the - wich causes it to be removed the
> next time you do remove.

in dselect's Select mode, move the cursor to the bash package and press
"H" to hold the package. This will prevent dselect from upgrading bash
until you either up/down-graded it by hand with dpkg or until you unhold
it by pressing "G".

Unless you want to find lots of shell scripts on your system which are
incompatible with the new bash 2.0 then you dont want to upgrade bash

If you've already installed bash 2.0 then you'll have to downgrade it
by hand with dpkg. ftp bash 1.14.7-2 from the stable tree and install
it with 'dpkg -i'. Remember to Hold bash again in dselect, otherwise
it will just be upgraded automatically again next time you run dselect


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: