[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PPP for non-root users?


Today I tried to put running pppd in Linux to dial to my
ISP. I've read the documentation in /usr/doc/ppp, and
the pon, poff, plog and pppd manpages, and setup the
files in /etc/ppp and the files /etc/ppp.*, plus /etc/hosts
and /etc/resolv.conf.

The result is: as root, all works well. The pon command
dials, and in 10 seconds are all working. But when I try
to use pon like a normal user, the system dials ok, I'm
connected, but I can't access sites with their names, only
with their IP addresses. I think the DNS IP addresses are
not being set...

I tried a "chmod u+s /usr/bin/pon /usr/bin/poff", but this
not seems to work.

One more thing: I've my login name and my brother's login
name configured in group dip in /etc/group.

Did I mistake something? Well, thanks in advance.

Alexander Gieg

By: Alexander Gieg
E-mail: agieg@brworld.com.br
URL: http://www.geocities.com/TimesSquare/3222
IRC: AlexG

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: