[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new sendmail version won't start

On Mon, 02 Dec 1996 11:18:45 +0100 Joop Stakenborg 
(jsg@iht1.kfih.azr.nl) wrote:

> Hello,
> While using dselect to install some new software, the program
> downloaded a new version of sendmail: 8.7.6-2.
> This version won't start however, here is the trace:
> Can anyone help me with this?

This is a problem when using sendmail 8.7.6-2 with older libc. You should upgrade libc to at least:
ii  libc5           5.2.18-11      The Linux C library version 5 (run-time libr

It installs flawlessly (some _bugged_ packages (netscape, octave, maelstrom and possibly one other) might fail unexpectedly, because they are bugged (bad mallocs which went undetected with the old libc5).
For netscape, the fix is to make a shell wrapper like this:

export LD_PRELOAD=/usr/lib/libgnumalloc.so.5
exec netscape-3.0 ${1+"$@"}

Notice that sendmail 8.7.6-2 fixes a serious security bug allowing any user to become root.

I don't know why this dependency over libc5 hasn't been added yet. Probably because all the developpers are busy carrying out 1.2.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: