[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrading from dpkg-1.0.5-0

I've got a system here with dpkg-1.0.5-0 on it, and I cannot
isntall eighter dpkg_1.2.6 or dpkg_1.4.0.3, both failing with:

   # dpkg -i dpkg-1.2.6.deb 
   (Reading database ... 6305 files and directories currently installed.)
   Preparing to replace dpkg (using dpkg-1.2.6.deb) ...
   dpkg: unknown option --assert-support-predepends
   Type dpkg --help for help about installing and deinstalling packages;
   Type dpkg -Dhelp for a list of dpkg debug flag values;
   Type dpkg-deb --help for help about manipulating *.deb files.
   dpkg: error processing dpkg-1.2.6.deb (--install):
    subprocess pre-installation script returned error exit status 2
   Errors were encountered while processing:

Does anyone know how to upgrade this?
Thanks very much.


# dpkg -l dpkg "libc*" "ld*so"
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name         Version   Rev  Description
ii  dpkg             1.0.5 0    Package maintenance system for Debian GNU/Linux
rn  libc                        (no description available)
un  libc.so.4                   (no description available)
in  libc5                       (no description available)
ii  ldso           1.8.5-1      The Linux dynamic linker, library and utilities

(libc5-recent also fails, with simmilar erros as dpkg).

joost witteveen
Use Debian/GNU Linux!

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: